Issue on .tasks index when trying to update Kibana from 6.8 to 7.6

I'm trying to upgrade my ES cluster from 6.8 to 7.6 but i'm facing an issue when I try to update my Kibana instance.

I get an error on the .tasks index :

FATAL  [index_not_found_exception] no such index [.tasks], with { resource.type="index_expression" &".tasks" & index_uuid="_na_" & index=".tasks" } :: {"path":"/_tasks/1IhkYQLWRwWBGlKnevpEeg%3A37345941","query":{},"statusCode":404,"response":"{\"error\":{\"root_cause\":[{\"type\":\"index_not_found_exception\",\"reason\":\"no such index [.tasks]\",\"resource.type\":\"index_expression\",\"\":\".tasks\",\"index_uuid\":\"_na_\",\"index\":\".tasks\"}],\"type\":\"resource_not_found_exception\",\"reason\":\"task [1IhkYQLWRwWBGlKnevpEeg:37345941] isn't running and hasn't stored its results\",\"caused_by\":{\"type\":\"index_not_found_exception\",\"reason\":\"no such index [.tasks]\",\"resource.type\":\"index_expression\",\"\":\".tasks\",\"index_uuid\":\"_na_\",\"index\":\".tasks\"}},\"status\":404}"}

I dont see any .tasks index in my cluster. So I tried to recreate a fresh new .tasks index but I still get an issue when starting Kibana :

FATAL [resource_not_found_exception] task [1IhkYQLWRwWBGlKnevpEeg:38778171] isn't running and hasn't stored its results :: {"path":"/_tasks/1IhkYQLWRwWBGlKnevpEeg%3A38778171","query":{},"statusCode":404,"response":"{\"error\":{\"root_cause\":[{\"type\":\"resource_not_found_exception\",\"reason\":\"task [1IhkYQLWRwWBGlKnevpEeg:38778171] isn't running and hasn't stored its results\"}],\"type\":\"resource_not_found_exception\",\"reason\":\"task [1IhkYQLWRwWBGlKnevpEeg:38778171] isn't running and hasn't stored its results\"},\"status\":404}"}

I'm not sure how to recover from this king of errors ?

Thank a lot for your Help !

Hi, where are you seeing this error? In the Kibana server logs?

Is there a stack trace? Can you provide the full error text?

Was there an attempted re-index operation?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.