Issue with elasticsearch on remote server


(Omar 1 Cpi2011 Brahimi) #1

I have installed elasticsearch on my server having this ip address W.X.Y.Z

I am able to run
./elasticsearch-6.3.2/bin/elasticsearch

The elasticsearch service is accessible on localhost (remote server) but I can't access it from my locale machine with the browser at this address http://W.X.Y.Z:9200/

Then I tried to change the elasticsearch-6.3.2/config/elasticsearch.yml file by adding the following lines (please see the attached screenshot)

network.host: 0.0.0.0
http.port: 9200

And at this time, I'm not able to run

./elasticsearch-6.3.2/bin/elasticsearch

Error is telling me

ERROR: [2] bootstrap checks failed
[1]: max number of threads [3903] for user [developer] is too low, increase to at least [4096]
[2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[2018-11-21T17:27:58,309][INFO ][o.e.n.Node               ] [b1qDVeW] stopping ...
[2018-11-21T17:27:58,346][INFO ][o.e.n.Node               ] [b1qDVeW] stopped
[2018-11-21T17:27:58,347][INFO ][o.e.n.Node               ] [b1qDVeW] closing ...
[2018-11-21T17:27:58,377][INFO ][o.e.n.Node               ] [b1qDVeW] closed
[2018-11-21T17:27:58,380][INFO ][o.e.x.m.j.p.NativeController] Native controller process has stopped - no new native processes can be started

(Mark Walkom) #2

You will need to make sure you have correctly applied all of these - https://www.elastic.co/guide/en/elasticsearch/reference/6.5/bootstrap-checks.html


(Omar 1 Cpi2011 Brahimi) #3

Sorry, this issue is reported here and it is solved