Unable to connect to elasticsearch from other machine


(yevsh) #1

I copied elasticsearch to a unix machine, and started it
../elasticsearch-5.6.1/bin>./elasticsearch

tested the connection:

curl 'localhost:9200/_cat/health?v'

and got

elasticsearch green

when I tired to connect remotely from windows machine , with ip of the machine I am getting error
This site can’t be reached

Also tried to modify elasticsearch.yml

and set

network.host: ip_of_the machine

Then, when I tried to start the elasticsearch got this error:

ERROR: [3] bootstrap checks failed
[1]: max file descriptors [16384] for elasticsearch process is too low, increase to at least [65536]
[2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[3]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk


(Christian Dahlqvist) #2

Your installation is failing the bootstrap checks, so you will need to fix that before you will be able to access it remotely. There is more information available in the documentation.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.