Issue with launching Kibana 4.0.2


(Adam Pawlikowski) #1

Greetings,

I'm following along the Official Logstash book (2013) and cannot get Kibana to launch. I get strange error messages:

{"@timestamp":"2016-01-14T02:06:28.943Z","level":"error","message":"unknown error","node_env":"production","error":{"message":"unknown error","name":"Error","stack":"Error: unknown error\n at respond (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/src/lib/transport.js:237:15)\n at checkRespForFailure (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/src/lib/transport.js:203:7)\n at HttpConnector. (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/src/lib/connectors/http.js:156:7)\n at IncomingMessage.bound (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/node_modules/lodash-node/modern/internals/baseBind.js:56:17)\n at IncomingMessage.emit (events.js:117:20)\n at _stream_readable.js:944:16\n at process._tickCallback (node.js:442:13)\n"}} {"@timestamp":"2016-01-14T02:06:28.947Z","level":"fatal","message":"unknown error","node_env":"production","error":{"message":"unknown error","name":"Error","stack":"Error: unknown error\n at respond (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/src/lib/transport.js:237:15)\n at checkRespForFailure (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/src/lib/transport.js:203:7)\n at HttpConnector. (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/src/lib/connectors/http.js:156:7)\n at IncomingMessage.bound (/opt/kibana-4.0.2-linux-x64/src/node_modules/elasticsearch/node_modules/lodash-node/modern/internals/baseBind.js:56:17)\n at IncomingMessage.emit (events.js:117:20)\n at _stream_readable.js:944:16\n at process._tickCallback (node.js:442:13)\n"}}

Not sure what I'm doing wrong.

Thanks


(Christian Dahlqvist) #2

That is a quite old version, and many improvements and enhancements have been made since. If you are just starting out, you are probably better off using the latest version or Elasticsearch, Logstash and kibana.


(Adam Pawlikowski) #3

Thank you. Yeah I ended up downloading a newer version of Kibana and it launched successfully.


(system) #4