It is safe to delete .kibana_1, .kibana_2 and kibana_task_manager_1?

I ask this because Im having trouble to get metricbeat dashboard working, and I found this link: https://github.com/elastic/kibana/issues/53878
where people say that deleting those indices you can get the dashboards working again

green open .kibana_task_manager_1 g_3ywTOcSjmQxsMwt5VYGg 1 1   2 1 80.8kb 40.4kb
green open .kibana_2              u8PwnljuQPiHIwMrUeJgSg 1 1 470 4  3.4mb    2mb
green open .kibana_1              Ju8f8hFzRnKqPzDyNMw5Gw 1 1   6 0   29kb 14.5kb

Hi

You shouldn't need to delete those indices, could you provide some details about the problem you're facing? which version of Kibana are you using?

Many thx & Best,
Matthias

Hi, Mathias

7.5.1 Elastic, Kibana
7.6.1 Metricbeat

I've try to create a custom index name

setup.dashboards.enabled: true
setup.dashboards.directory: "/usr/share/metricbeat/kibana"
setup.dashboards.index: "test*"

setup.template.name: "test_mtb"
setup.template.pattern: "test_mtb*"

output.elasticsearch:
  hosts: ["myip"]
  username: "myusr"
  password: "mypass"
  index: "test"

setup.ilm.enabled: auto
setup.ilm.rollover_alias: "test_mtb"
setup.ilm.pattern: "{now/d}-000001"

With this configuration some visualizations doesn't appears and show me this error

Could not locate that index-pattern (id:test*), [click here to re-create it](#/management/kibana/index_pattern)

so kibana is looking for a visualization with id of "test*" instead of alphanumeric key, and in some cases I can manualy change the id in the visualization Json to get it to work

[ {
    "name": "kibanaSavedObjectMeta.searchSourceJSON.index",
    "type": "index-pattern",
    "id": "test*" # replaced this for the id of the index
 }]

Im monitoring docker also, but the dashboard of docker doesnt show any result, but if I go to discovery I can find data of the docker containers

Maybe it‘s because you‘re using metricbeat in a minor version ahead of kibana, I’ll check if this is a known issue
Best,
Matthias