[KBN-ES Development] yarn es snapshot doesn't work

Hi all,
i'm trying to start kbn development enviroment to create my first plugin.
I follow the guide in this link: getting started

  1. fork from kibana repo
  2. clone the repo on my local
  3. bootstrap kibana

I can bootstrap properly kibana with a success message at the end, i can also start kibana with:

yarn start

but i'm finding problems with elastic and the command:

yarn es snapshot.

Basically it remains stucked with this trace:

C:\Users\mario.rossi\kibana>yarn es snapshot --version 7.13.2
yarn run v1.22.10
warning package.json: "dependencies" has dependency "@elastic/apm-rum" with range "^5.8.0" that collides with a dependency in "devDependencies" of the same name with version "^5.6.1"
warning package.json: "dependencies" has dependency "@elastic/apm-rum-react" with range "^1.2.11" that collides with a dependency in "devDependencies" of the same name with version "^1.2.5"
$ node scripts/es snapshot --version 7.13.2
 info Installing from snapshot
   │ info version: 7.13.2
   │ info install path: C:\Users\mario.rossi\kibana\.es\7.13.2
   │ info license: basic
   │ info Downloading snapshot manifest from https://storage.googleapis.com/kibana-ci-es-snapshots-daily/7.13.2/manifest-latest-verified.json
   │ info verifying cache of https://storage.googleapis.com/kibana-ci-es-snapshots-daily/7.13.2/archives/20210613-194436_04715f2a747/elasticsearch-7.13.2-SNAPSHOT-windows-x86_64.zip
   │ info etags match, reusing cache from 2021-06-22T15:23:17.620Z
   │ info install directory already exists, removing
   │ info extracting C:\Users\mario.rossi\kibana\.es\cache\elasticsearch-7.13.2-SNAPSHOT-windows-x86_64.zip
   │ info extracted to C:\Users\mario.rossi\kibana\.es\7.13.2
   │ info created C:\Users\mario.rossi\kibana\.es\7.13.2\ES_TMPDIR

after three hours, the process is not finished yet. I think something is not working but i don't know how to solve this. Any help?
I also tried with default version 8.0.0. with the same result.
Thx in advance.

yarn es snapshot is the command to run a local Elasticsearch cluster for your development, the process doesn't automatically terminate to keep Elasticsearch running.

Were you able to successfully run yarn kbn bootstrap? That process is typically the slowest, especially because Windows is a slower environment.

yes i was able to successfully run yarn kbn bootstrap. But when i try:

yarn start

in order to rise a kibana server, it tells me that: no elasticsearch istance in running.

Right. Kibana does require a running Elasticsearch instance to connect to- that is the purpose of yarn es snapshot, but if that command is giving you issues you can connect Kibana to any test cluster of your choice.

I find out, that if i try to force elastic snapshot 8.0.0. to start with

./bin/elasticsearch

i get an error for: unknown setting.

but if Try to install elastic snapshot 7.13.2 and i force it to run in the same way that before:

./bin/elasticsearch

Elastic runs correctly. Unfortunately at this point kibana gives me this error:

server log [17:23:07.439] [error][savedobjects-service] This version of Kibana (v8.0.0) is incompatible with the following Elasticsearch nodes in your cluster: v7.13.2 @ 127.0.0.1:9200 (127.0.0.1)

While I can't guarantee compatibility between 7.13.2 and 8.0, you might be able to test it using yarn start --elasticsearch.ignoreVersionMismatch=true

thank you so much, with your last command, i'm correctly running kibana on my localhost:5601.
Now i can go on in kibana plugin development.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.