Kibana 4.4 "No default index pattern"?


(Ivo Stoyanoff) #1

Newbie question - ES2.2 and Kibana 4.4.1

I am following "Getting started" guide.
Loaded accounts and logstash sample data.

Added 2 indices for them - I see the fields, set @timestamp.
I see indexes and docs are OK in ES.

I still see "Warning: no default index pattern" - and I tried the green star to set default index to ba* or logstash-*

Trying "discover" keeps saying: "Please specify a default index pattern".
Restarting kibana doesn't help.

Error: Please specify a default index pattern
KbnError@http://localhost:5601/bundles/commons.bundle.js?v=9693:57416:21
NoDefaultIndexPattern@http://localhost:5601/bundles/commons.bundle.js?v=9693:57569:6
loadDefaultIndexPattern/<@http://localhost:5601/bundles/kibana.bundle.js?v=9693:98910:1
processQueue@http://localhost:5601/bundles/commons.bundle.js?v=9693:42357:29
scheduleProcessQueue/<@http://localhost:5601/bundles/commons.bundle.js?v=9693:42373:28
...

How to fix this? I don't see any other way to set the default index...


(Mark Walkom) #2

Is it saying this on the Discover page? If so, just go to the Setting page, select an index and click the green star to make that the default one.


(Ivo Stoyanoff) #3

Something was messed up with my installation on Ubuntu (I upgraded from older ES/Kibana).
I tried on different VM and everything works as expected.
All good...


(system) #4