Kibana 5.6 unable to load licence


(Troy Baird) #1

Not sure how to resolve this one...

After updating to 5.6.0 i seem to be unable to load into kibana.
image

Have tried removing x-pack on both, Kibana loads up happily after this.
Also double checked my licence within elasticsearch itself which all checks out.
image

Was there possibly a configuration change between 5.5 and 5.6 that i may have missed?
Upgrade process was followed as normal, Upgrade via apt-get; remove x-pack and reinstall.

I run my kibana instance behind a local network thus authentication via x-pack is disabled within elasticsearch.


(Tim Vernum) #2

The error message you received is not specifically a licence problem, it just indicates that Kibana couldn't communicate successfully with Elasticsearch, and therefore couldn't determine the license state.

You wrote:

I run my kibana instance behind a local network thus authentication via x-pack is disabled within elasticsearch.

Can you clarify exactly what you mean here? Have you turned off xpack security entirely within ES?

If so, have you also disabled security in Kibana?


(Troy Baird) #3

In terms of disabling xpack security, i mean in my elasticsearch.yml i have " xpack.security.enabled: false"

I have now added this to my kibana.yml issue still stands, although improved.


null operations look like i may need to reinstall the kibana instance?

Testing manually using curl to access the .kibana index looks normal

{".kibana":{"aliases":{},"mappings":{"server":{"dynamic":"strict","properties":{"uuid":{"type":"string","index":"not_analyzed"}}},"graph-workspace":{"properties":{"description":{"type":"string"},"kibanaSavedObjectMeta":{"properties":{"searchSourceJSON":{"type":"string"}}},"numLinks":{"type":"integer"},"numVertices":{"type":"integer"},"title":{"type":"string"},"version":{"type":"integer"},"wsState":{"type":"string"}}},"config":{"properties":{"buildNum":{"type":"string","index":"not_analyzed"},"defaultIndex":{"type":"string"},"discover:aggs:terms:size":{"type":"long"},"xPackMonitoring:allowReport":{"type":"boolean"},"xPackMonitoring:showBanner":{"type":"boolean"}}},"_default_":{"dynamic":"strict"},"url":{"dynamic":"strict","properties":{"accessCount":{"type":"long"},"accessDate":{"type":"date","format":"strict_date_optional_time||epoch_millis"},"createDate":{"type":"date","format":"strict_date_optional_time||epoch_millis"},"url":{"type":"string","fields":{"keyword":{"type":"string","index":"not_analyzed","ignore_above":2048}},"fielddata":false}}},"visualization":{"properties":{"description":{"type":"string"},"kibanaSavedObjectMeta":{"properties":{"searchSourceJSON":{"type":"string"}}},"savedSearchId":{"type":"string"},"title":{"type":"string"},"uiStateJSON":{"type":"string"},"version":{"type":"integer"},"visState":{"type":"string"}}},"dashboard":{"properties":{"description":{"type":"string"},"hits":{"type":"integer"},"kibanaSavedObjectMeta":{"properties":{"searchSourceJSON":{"type":"string"}}},"optionsJSON":{"type":"string"},"panelsJSON":{"type":"string"},"refreshInterval":{"properties":{"display":{"type":"string","fields":{"keyword":{"type":"string","index":"not_analyzed","ignore_above":256}},"fielddata":false},"pause":{"type":"boolean"},"section":{"type":"long"},"value":{"type":"long"}}},"timeFrom":{"type":"string"},"timeRestore":{"type":"boolean"},"timeTo":{"type":"string"},"title":{"type":"string"},"uiStateJSON":{"type":"string"},"version":{"type":"integer"}}},"timelion-sheet":{"properties":{"description":{"type":"string"},"hits":{"type":"integer"},"kibanaSavedObjectMeta":{"properties":{"searchSourceJSON":{"type":"string"}}},"timelion_chart_height":{"type":"integer"},"timelion_columns":{"type":"integer"},"timelion_interval":{"type":"string"},"timelion_other_interval":{"type":"string"},"timelion_rows":{"type":"integer"},"timelion_sheet":{"type":"string"},"title":{"type":"string"},"version":{"type":"integer"}}},"search":{"properties":{"columns":{"type":"string"},"description":{"type":"string"},"hits":{"type":"integer"},"kibanaSavedObjectMeta":{"properties":{"searchSourceJSON":{"type":"string"}}},"sort":{"type":"string"},"title":{"type":"string"},"version":{"type":"integer"}}},"index-pattern":{"properties":{"fieldFormatMap":{"type":"string"},"fields":{"type":"string"},"intervalName":{"type":"string"},"notExpandable":{"type":"boolean"},"timeFieldName":{"type":"string"},"title":{"type":"string"}}}},"settings":{"index":{"creation_date":"1478757612671","number_of_shards":"1","number_of_replicas":"1","uuid":"z7jNdqqpRz2KTeg_U8wHow","version":{"created":"2040199","upgraded":"5060099"}}}}}

and the elasticsearch stack itself is standing fine

Yellow is due to a single index which is not replicated currently.

Checking with curl all seems to be working well.


(Tim Vernum) #4

It looks like it might be related to this issue: https://github.com/elastic/kibana/issues/13950


(Troy Baird) #5

Bingo!

ran script, everything is working great!

on the note of kibana, changes to both the gauge values and graph colours is perfect, back to being usable!


(Mark Walkom) #6

Side note, you have way too many shards and you should reduce that count ASAP.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.