Kibana 5 failed to install on CentOS 7 - SOLVED


(Vishal Sharma) #1

hi,
I have followed the official document and tried installing Elastic Stack 5. When i try to do it i get below

Dependencies Resolved

================================================================================================================================================================================================
Package Arch Version Repository Size

Updating:
elasticsearch noarch 5.0.0_rc1-1 logstash-5.x 31 M
kibana x86_64 5.0.0_rc1-1 logstash-5.x 38 M
logstash noarch 1:5.0.0-1 Kibana-5.x 101 M

Transaction Summary

Upgrade 3 Packages

Total size: 170 M
Is this ok [y/d/N]: y
Downloading packages:

Package kibana-5.0.0-rc1-x86_64.rpm is not signed

Can someone please help me.
Regards


(Aadira Menon) #2

Yeah!!I'm too facing the same problem !!


(Vishal Sharma) #3

so no solution?


(Vishal Sharma) #4

devs should sign the rpm. help please


(CJ Cenizal) #5

Hi Vishal and Aadira,

Sorry about that! Our RC1 builds weren't signed, but our GA builds are. Please go to https://www.elastic.co/guide/en/kibana/current/rpm.html and follow the instructions for "Installing from the RPM Repository." Let me know if you have any more questions.

Thanks,
CJ


(Vishal Sharma) #6

Hi CJ,

Thank you very much for your reply. Do you know when the RC1 builds will be signed ?
Regards
VIshal


(Christian Dahlqvist) #7

Why would you want to use the RC1 build now that the GA build is available??


(Vishal Sharma) #8

Hi Christian,

No i do not want to install RC1 build just want to follow the OS repository. I hope it will be updated soon.
Regards
Vishal


(Court Ewing) #9

@Vishal_Sharma1 The GA builds are available in package repositories (see the install documentation linked in a previous comment for details). The RC1 builds will never be signed, but even if they were, I'd recommend that you use the GA builds anyway. The RC1 builds are not supported and they include some critical bugs that were fixed in the GA builds.


(Vishal Sharma) #10

hey Court,
the first thing i have done is to follow the official guide. The process for installing it using sudo yum install kibana, it's still giving me the same error and trying to install kibana-5.0.0-rc1-x86_64.rpm so what about it?
Regards
Vishal


(Court Ewing) #11

Open up your /etc/yum.repos.d/kibana.repo file (assuming you're on a redhat-based distro) and make sure the [kibana-5.x] block is exactly how it appears in: https://www.elastic.co/guide/en/kibana/current/rpm.html#rpm-repo

Specifically, make sure it does not include -prerelease anywhere in the baseurl, but the best way would be to simply replace the entire existing block with the one from the docs, just to be sure.

Note that modifying the repo file will probably require sudo.


(Vishal Sharma) #12

well as i have said earlier, i followed the official guide. My kibana repo looks like below which is exactly same as on official guide
[kibana-5.x]
name=Kibana repository for 5.x packages
baseurl=https://artifacts.elastic.co/packages/5.x/yum
gpgcheck=1
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch
enabled=1
autorefresh=1
type=rpm-md

and still it tries to download the RC1.
Regards
Vishal


(Lee Drengenberg) #13

I just updated my repo file (same as Vishal's repo file) and upgraded from Kibana 4.6.1 to 5.0 and I got the correct GA 5.0 version;

===============================================================================================================================================================================================================================
 Package                                            Arch                                               Version                                             Repository                                                     Size
===============================================================================================================================================================================================================================
Updating:
 kibana                                             x86_64                                             5.0.0-1                                             elasticsearch-5.x                                              39 M

Transaction Summary
===============================================================================================================================================================================================================================
Upgrade  1 Package

Updated:
  kibana.x86_64 0:5.0.0-1                                                                                                                                                                                                      

Then I did yum remove kibana and yum install kibana just to make sure a clean install worked like the upgrade.

Maybe you have Kibana listed in more than one repo file? I had that problem once. You could check with something like this;
grep -ri kibana /etc/yum.repos.d/*

Or maybe you need a yum clean or yum updateinfo?

Regards,
Lee


(Vishal Sharma) #14

Hello Lee

the issue is solved, it was my fault. I had -prerelease in logstash.repo in base url, which was pulling the RC1 version of Kibana.
Regards
V


(system) #15