Kibana 6.5.1 Elastic Cloud Kibana Browser 100%


(Dallas Toth) #1

Kibana 6.5.1 Elastic Cloud
Tested Chrome Version 70.0.3538.110 (Official Build) (64-bit)
Internet Explorer 11.407.17134.0
Browser Hangs on Visualizations With CPU 100% In Chrome TaskManager
No performance issues in Elastic Cloud, I've played around with Sizing and no changes made to the Deployment have any effect on the Browser cpu usage.


(Dallas Toth) #2

Another note I also tried Kibana Container 6.5.1 in AWS and still get the same result.

I do have another cluster with the same index's on version 5.6.1 that does not have this issue.

I am currently trying to move to my 6.5.1 deployment but this issue is a show stopper.


(Tyler Smalley) #3

Can you give some insights into the visualizations used on the dashboard? Are you upgrading to 6.5.1 from a previous version where these visualizations were functioning properly?


(Dallas Toth) #5

I have 1 control vis which are filters and 4 tables for the data in the 6.5.1 setup.

The same data in the 5.6.1 was only using tables since control wasn't available and 8 tables since that is how I was using filters.

Both are the exact same for data since the way I got the data in was by restoring a snapshot with those specific indexes from the 5.6.1 to the 6.5.1.

They are both in elastic cloud if you want to investigate.
I can provide login details since both data sets are anonymized demo data.


(Dallas Toth) #6

I managed to nail this down for you.
Here is a video of the issue now only in the Table Vis. What show is the exact same Vis as it is in 5.6.1 vs 6.5.1. On the exact same index's in each. 1st I show 5.6.1 with a Alt f5 to refresh the data to show time to render with the task manager up. Then I jump into 6.5.1 using the same data and visual but this time I step thru the different Metrics and show the Task Manager as you will see it gets worse and worse as I add the columns. I believe it has to do with the Average Buckets, To the point where it will hang, Sum Buckets are working fine. Then I jump back to the 5.6.1 and show the exact same adding of columns so you can get a visual of the time it took in 5.6.1. Both of my Deployments are also using the same sizing of 8gb 2 zones. "b7be70" and "7266ca"


(Dallas Toth) #7

any other info i could provide to help diagnose this issue?


(Dallas Toth) #8

Just upgraded to 6.5.2 and issue is still present.


(Tyler Smalley) #9

Sorry for the delay, tracked down the issue - it's being tracked here: https://github.com/elastic/kibana/issues/17822


(Dallas Toth) #10

Thx I added some more info to that ticket.
I found that the same aggregation in TSVB does not have the same performance issues and added a video showing that.
It really does look to be related to Table Visualization Average Buckets.


(Dallas Toth) #11

Issue still present in 6.5.3