Kibana 7.13/7.14 Uptime setting does not allow selecting email connector

We are unable to select email connector in Default connectors drop down on Uptime settings page.

The email action/connector can be selected through Create rule

The email connector was returned by /api/actions, so wonder why it is not displayed on the UI

[{
    "id": "94aa2f30-0a2d-11ec-a1bf-ef18a994b933",
    "actionTypeId": ".email",
    "name": "Email connector",
    "isMissingSecrets": false,
    "config": {
      "hasAuth": false,
      "from": "aa@aa.com",
      "host": "localhost",
      "port": 25,
      "service": null,
      "secure": null
    },
    "isPreconfigured": false,
    "referencedByCount": 0
  }, {
    "id": "539e4a61-d5ce-4df3-83bf-ad204ceef02b",
    "actionTypeId": ".server-log",
    "name": "Monitoring: Write to Kibana log",
    "config": {},
    "isMissingSecrets": false,
    "isPreconfigured": false,
    "referencedByCount": 14
  }, {
    "id": "42a6360c-4e13-4de3-9a89-39fa8a560ab4",
    "actionTypeId": ".webhook",
    "name": "MS Teams ES alerting test",
    "config": {
      "method": "post",
      "url": "",
      "headers": null,
      "hasAuth": false
    },
    "isMissingSecrets": false,
    "isPreconfigured": false,
    "referencedByCount": 2
  }
]

Hi @hendry.lim - you're right, today the UI doesn't display email as an option for the simple alert. Today, that's not a supported use case, but it's a feature we intend to implement in the future, as you are not the first person who has requested this.

I've created an enhancement request to track the progress of it here. If you need to use email alerts for the time being, the recommended action would be to create a rule that encompasses the monitors you want to alert on using the Create rule dialogue that you have shown in your post.

1 Like