Kibana 7 can't load index pattern

Kibana: 7.0.1
ES: 7.0.1

When i create index pattern in Kibana, it can load the fields in the indexes. However, when i go to discovery page, it prompts me "In order to visualize and explore data in Kibana, you'll need to create an index pattern to retrieve data from Elasticsearch."

I can reload this index pattern by ID like this though:
/app/kibana#/management/kibana/index_patterns/83c2bf60-7188-11e9-8feb-fd1dd5f8f608?_g=()&_a=(tab:indexedFields)

Any advise?

2 Likes

Also, when i go to Saved Objects, i have this error "Unable find saved objects Error: Bad Request"

response log:
"res":{"statusCode":400,"responseTime":68,"contentLength":9},"message":"GET /api/saved_objects/_find?per_page=20&page=1&fields=title&fields=id&search_fields=title&type=index-pattern&type=visualization&type=dashboard&type=search&sort_field=type&default_search_operator=OR 400 68ms - 9.0B"}

It turns out i have to manually choose default space before i can save objects.
I think the default space should be automatically selected

Go to management-> advanced settings and set defaultIndex to 83c2bf60-7188-11e9-8feb-fd1dd5f8f608

Good to know, Thanks @Nathan_Reese

Hello elastic team.
I have the same issue using ES 7.0.0 and kibana 7.0.1. I can create an index pattern but when i go to discovery page , it prompts me "In order to visualize and explore data in Kibana, you'll need to create an index pattern to retrieve data from Elasticsearch.".
I already try the word around proposed by @Nathan_Reese but it still does not work for me

@JackLandry Do you have any indices in Elasticsearch and Index patterns in Kibana? If not, load some sample data to get everything initialized. Sample data will allow you to explore Kibana without having to setup any data flows.

@Nathan_Reese yes i have some data in my cluster and i also try to load the sample data as describe in kibana documentation but still have the same issue. I am able to create index pattern but when i go to discovery page i have the same error message.

Have you set defaultIndex advanced setting to an saved object id of one of your index patterns?

Yes I set this setting but still have the same issue
here some pictures :
the list of my indices


Index-pattern that i have created

My defaultIndex setting :

1 Like

The advanced settings is one thing. But from previous Kibana version, 2.x, 5.x and 6.x, the default index pattern should be created together with the creating of the first index pattern.

Indeed, from .kibana index, I could see the created partterns' id exist. i could even load the pattern by modifying the kibana url to specify pattern id. Somehow the newly created pattern name was not presenting in the Kibana "Index Patterns" page. The Discovery and other pages were also complaining no index pattern defined.

The difference in my case was that the "D" space indicator was instead a yellow "E" (E for error). After I changed to "D" space, everything back to normal.

I have the same problem using kibana & elasticsearch 7.0.1 docker images.

  1. I successfully create an index pattern and can see the fields of my index
  2. I can see the index patterns when searching .kibana index
  3. However, the discover page doesn't find the index patterns (Using chrome network I saw this request returns empty results https://.../api/saved_objects/_find?type=index-pattern&fields=title&per_page=10000)

Restarting my kibana docker I can now see all my index patterns.
Then you need to set a default index pattern to use the Discover page.
After that it worked.

I have the same problem with ES 7.1.0 and kibana 7.1.0. I have also tried the newest kibana 7.1.1, but problem still occurrs. @JackLandry did you find any solution?

I have finally found solution in another discussion - set kibana.index in kibana.yml to some new name, which causes creating new index for kibana. After restart index patterns work fine.

1 Like

Hello @Wojciech_Kuligowski in my case there was something wrong in my custom kibana index mapping. Fixing the kibana index mapping solved the probleme for me.

genius... but isn't it an error?

I had this issue when i stood up a new 7.0.1 stack, to fix it i just removed the existing .kibana index and restarted kibana.

I had the same / a similar issue. It seems that Kibana sets the wrong type on the type field in it's index mapping. It sets it as text instead of keyword which I guess means that Elasticsearch will not reliably return exact matches when querying for Saved objects of a specific type.

Hi @JackLandry, can you share a bit more about what's wrong with your custom index and how did you fix it?