Kibana - Auto Refresh Default Change


I would like to change the auto refresh on my kibana to 1 min by default.

Currently the default is 15mins.

Can anyone help as to where this can be done? Permanently. Thanks.

Editing the refresh_intervals.js file works but that might be a bit fragile. The file would get overwritten when you upgrade Kibana so you will have to go change it again.

What about using the timepicker:refreshIntervalDefaults Advanced Setting in Kibana? You can get to it by clicking on Management (the gear icon in the left nav) > Advanced Settings . Changing its value to something like the following might work for you:

  "display": "1m",
  "pause": false,
  "value": 5

This should work I believe

Hi @ek9boy,

You can change the same in kibana GUI as well. Please refer below screenshot for the same.

Harsh Bajaj

Hi, Thanks for this.

However i require a permanent fix, that will get saved and become a default.



This works!

Could you just explain what Display, pause & value refer too?

"display" = the actual 1 minute you wanted
"pause" false = the refresh is running, is set to true it's paused
"value" 5 = the order of count from 5s to 1m

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.