Kibana data table


(Raj) #1

Hi All,

I want to export the raw file from the created data-table ,
so i created data table with seven columns and I was able to download the raw file, but I want to add one more column which is 8th column which is solution column.After adding solution to the datatable ,but some of the documents were missing , after analyzing I found due to one particular document which has solution like this

this solution is not like other solution, its not in one line or one paragraph

Please any one let me know how to fix this issue,as its really important for us.

Thanks,
Raj


(Stacey Gammon) #2

hmmm, the new lines, nor tabs should be a problem. I was able to successfully export data that contained new lines and tabs:

what exactly is the error you are seeing? The values aren't showing up in the data table?

If you can paste the contents of the field I can see if it works on my end. Maybe there are some other special characters messing it up. This is the test data I am using:

POST tabs/data/_bulk
{ "index" : { } }
{  "user": "Sam", "responseTime": 5, "roundTripTime": 10, "query": "bird\t\t:\tcolor\n:\nchickadee\t\t:\tblack and white\nblue jay\t\t:\tblue",   "@timestamp": "2017-09-29T13:00:00.000Z" }

(Raj) #3

Hi Stacey,

Thank you so much for the reply :slight_smile:

Let me explain you the issue ,

I have created a datatable in kibana like below screenshot , i get around 120 documents, everything works perfectly fine.

but now I would like to add one more field which is the solution,and when I add I get only 90 documents , 30 documents are missing .Please find the below screenshot

I figured it out its because of this particular solution, which occupies more space and has new lines.The solution looks like this.

The reason am creating this datatable is to export the raw csv file and send it to different teams,because this is really important.

Hope this explains it .
Please do help me in figuring out this problem,so that I want to export all the 120 documents without missing any of the documents irrespective of any value length.

Thanks,
Raj


(Stacey Gammon) #4

Can you send a screenshot of the entire data tables and how you are coming up with the 120 and 90 count for documents? I tried to repro but the number of documents still adds up to the total count.

Are you sure the size variable is set to something high enough to not limit the results?

Can you also paste the Elasticsearch request and response body from both a version of the data table with the column that has newlines in it, and a version without?

You can get the request and response from the spy panel.


(Raj) #5

Hi Stacey,

Please find the screenshot for a data table without the field solution

please see at the bottom of the page totaly 82 documents.

Request screenshot

Now I will attach the another table with solution field added , please not the number of documents at the bottom of the page ,the document count is reduced from 82 to 61

Request screenshot

And more thing all the fields are set to 2000.

I have increased the size of the table from 2000 to 200000 still the same, no changes

Thanks,
Raj


(Stacey Gammon) #6

Is it possible some of your documents are missing the solution field? This would cause a fewer number of rows to display.

You can double check this by creating a painless field, like so:

Then sorting on it in discover (over the same time range as your data table)

You can see the lower number of values in the doc table once I add query:

here is a total count of 9 documents:

Here you can see only 8 documents counted:

Could this perhaps be the situation you are running into?


(Raj) #7

Exactly ,
wherever I have this solution, that document is removed from the table table, thats why it reduced from 82 to 61.The solution looks like this below screenshot.If the soultion is single line or one small paragraph its refelecting in the datatable.


(Raj) #8

Please let me know , what should I do in this case.


(Stacey Gammon) #9

Were you able to determine if any documents were missing the solution field? If this was the case, then a lower number of documents appearing in the data table would be expected. I have not been able to repro a document dropping from the result set because it was set up like a paragraph. If you can copy/paste the exact contents of that specific solution I can double check on my end, though some testing doesn't seem to help.

On the data table, can you filter on Solution:Apply* in the query bar, so we can be sure your document is not showing up on one of the later pages?

Also, what version of Kibana are you running? Perhaps this is something that was fixed in the latest version that I am testing on.


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.