Kibana Discover page sorting when Hide 'Time' column enabled

Background:

  • Kibana and Elasticsearch version: 7.9.2, installed with yum from repo elasticsearch-7.x, running on free license.
  • Platform: CentOS 7
  • I had enabled Kibana's Advanced setting titled Hide 'Time' column (doc_table:hideTimeColumn).

Problem:
Column sorting in my Discover page did not seem to operate properly. If I clicked on the small up/down arrows at the top of a column, the arrow display would update properly but the column displayed a repeating series of that column rather than a simple sort.

Diagnosis:
It turns out that Kibana sorts on the timestamp column by default, whether or not this column is visible.

Workaround:
Once I made this discovery I was able to resolve this by manually adding the 'timestamp' column to my display. This allowed me to then disable sorting by time, which in turn allowed me to sort my Discover screen by other fields without interaction from the timestamp field.

Possible upgrade:
Now that I understand what is going on I am less concerned, but think it might be advisable to disable sorting by time when Kibana's Advanced Hide 'Time' column option is enabled.

@CODE-REaD Welcome to the Discuss forum!
The situation you're describing and the interesting work-around certainly sounds like it's un-intended behavior.
I'd like to dig into this a bit more and see if I can reproduce it. If so, we can open a feature request (if the behavior is actually intentional) or a bug issue in Github (if it's not intentional behavior).
What version of the stack are you running?
How are you running the stack? e.g. from source, with docker etc
What license are you running on? Some features are only available on higher license tiers.
An example index with mapping (better yet: some sample data :wink:)
Any logs you might have (server side too if you're running from source). You can get detailed server side logs from Kibana, with the following settings in your kibana.yml file:
elasticsearch.logQueries: true
logging.verbose: true

Note that with those settings, Kibana will become very chatty!

@cheiligers, thank you for your interest and your speedy response!

I updated my topic with information on my runtime environment.

I strongly suspect anyone can replicate my findings so have not at this time included sample indexes or log files. If that is not the case, let me know and I will furnish them.