Kibana empty dashboard

I have the following is showing up when I pull up my kibana dashboard:

http://192.168.10.25/#/dashboard

{{dashboard.current.title}}

When I tail my logs I see the following
2014/05/14 13:31:45 [error] 17152#0: *7 open()
"/var/www/kibana/app/diashboards/dashboard" failed (2: No such file or
directory), client: 192.168.11.53, server: 192.168.10.25, request: "GET
/app/diashboards/dashboard HTTP/1.1", host: "192.168.10.25"

I have been pulling my hair out over this, all help would be appreciated

This is my config.js

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5 
 * ==== elasticsearch 
 * 
 * The URL to your elasticsearch server. You almost certainly don't 
 * want +<a href="http://localhost:9200+">http://localhost:9200+ here. 

Even if Kibana and Elasticsearch are on
* the same host. By default this will attempt to reach ES at the same
host you have
* kibana installed on. You probably want to set it to the FQDN of your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",
/*elasticsearch: "http://"+window.location.hostname+":9200",

/** @scratch /configuration/config.js/5 
 * ==== default_route 
 * 
 * This is the default landing page when you don't specify a dashboard 

to load. You can specify
* files, scripts or saved dashboards here. For example, if you had
saved a dashboard called
* `WebLogs' to elasticsearch you might use:
*
* +default_route: '/dashboard/elasticsearch/WebLogs',+
*/
default_route : '/dashboard/file/default.json',

/** @scratch /configuration/config.js/5 
 * ==== kibana-int 
 * 
 * The default ES index to use for storing Kibana specific object 
 * such as stored dashboards 
 */ 
kibana_index: "kibana-int", 

/** @scratch /configuration/config.js/5 
 * ==== panel_name 
 * 
 * An array of panel modules available. Panels will only be loaded when 

they are defined in the
* dashboard, but this list is used in the "add panel" interface.
*/
panel_names: [
'histogram',
'map',
'pie',
'table',
'filtering',
'timepicker',
'text',
'hits',
'column',
'trends',
'bettermap',
'query',
'terms',
'stats',
'sparklines'
]
});
});

ngix (default)

/** @scratch /configuration/config.js/1

  • == Configuration
  • config.js is where you will find the core Kibana configuration. This
    file contains parameter that
  • must be set before kibana is run for the first time.
    */
    define(['settings'],
    function (Settings) {

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +http://localhost:9200+ here. Even if Kibana and Elasticsearch 

are on
* the same host. By default this will attempt to reach ES at the same
host you have
* kibana installed on. You probably want to set it to the FQDN of your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9ed20394-75a7-43d4-9343-99b72eec8df8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I think you have extra quotes causing a problem, try - elasticsearch: "
http://192.168.10.25:9200",

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 15 May 2014 05:58, itbladehq3@gmail.com wrote:

I have the following is showing up when I pull up my kibana dashboard:

http://192.168.10.25/#/dashboard

{{dashboard.current.title}}

When I tail my logs I see the following
2014/05/14 13:31:45 [error] 17152#0: *7 open()
"/var/www/kibana/app/diashboards/dashboard" failed (2: No such file or
directory), client: 192.168.11.53, server: 192.168.10.25, request: "GET
/app/diashboards/dashboard HTTP/1.1", host: "192.168.10.25"

I have been pulling my hair out over this, all help would be appreciated

This is my config.js

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +<a href="http://localhost:9200+">http://localhost:9200+ here.

Even if Kibana and Elasticsearch are on
* the same host. By default this will attempt to reach ES at the same
host you have
* kibana installed on. You probably want to set it to the FQDN of
your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",
/*elasticsearch: "http://"+window.location.hostname+":9200",

/** @scratch /configuration/config.js/5
 * ==== default_route
 *
 * This is the default landing page when you don't specify a dashboard

to load. You can specify
* files, scripts or saved dashboards here. For example, if you had
saved a dashboard called
* `WebLogs' to elasticsearch you might use:
*
* +default_route: '/dashboard/elasticsearch/WebLogs',+
*/
default_route : '/dashboard/file/default.json',

/** @scratch /configuration/config.js/5
 * ==== kibana-int
 *
 * The default ES index to use for storing Kibana specific object
 * such as stored dashboards
 */
kibana_index: "kibana-int",

/** @scratch /configuration/config.js/5
 * ==== panel_name
 *
 * An array of panel modules available. Panels will only be loaded

when they are defined in the
* dashboard, but this list is used in the "add panel" interface.
*/
panel_names: [
'histogram',
'map',
'pie',
'table',
'filtering',
'timepicker',
'text',
'hits',
'column',
'trends',
'bettermap',
'query',
'terms',
'stats',
'sparklines'
]
});
});

ngix (default)

/** @scratch /configuration/config.js/1

  • == Configuration
  • config.js is where you will find the core Kibana configuration. This
    file contains parameter that
  • must be set before kibana is run for the first time.
    */
    define(['settings'],
    function (Settings) {

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +http://localhost:9200+ here. Even if Kibana and

Elasticsearch are on
* the same host. By default this will attempt to reach ES at the same
host you have
* kibana installed on. You probably want to set it to the FQDN of your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9ed20394-75a7-43d4-9343-99b72eec8df8%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/9ed20394-75a7-43d4-9343-99b72eec8df8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624aGML4n4LLh9R91sLp7GzoD7vWYc4fH2OyD_se69vWcDQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Here are the versions that I'm running:

Kibana version

Kibana 3.1.2-07bbd7e
eeded13255f154eaeceb4cf83105e4b4 kibana-3.1.2.tar.gz

Logstash version

[root@elk ~]# /opt/logstash/bin/logstash version
logstash 1.4.2-modified
1db9f0864ff4b89380b39c39bc419031 logstash-1.4.2-1_2c0f5a1.noarch.rpm

Elasticsearch version

[root@elk ~]# /usr/share/elasticsearch/bin/elasticsearch -v
Version: 1.4.2, Build: 927caff/2014-12-16T14:11:12Z, JVM: 1.7.0_51
6e2061f0734f9dbab263c1616701c1fe elasticsearch-1.4.2.noarch.rpm

OS

CentOS (CentOS-7.0-1406-x86_64-Everything.iso)
Installed packages: Basic Web Server + Development tools

Logstash runs fine. Elasticsearch runs fine. Kibana runs, but only shows
the screenshot shown below at, https://logstasht/#/dashboard

https://lh3.googleusercontent.com/-8mIiX5lKJ_U/VKpmMkRSftI/AAAAAAACYWM/v4LxHMzEAGI/s1600/kibana.png

On Wednesday, May 14, 2014 6:56:03 PM UTC-4, Mark Walkom wrote:

I think you have extra quotes causing a problem, try - elasticsearch: "
http://192.168.10.25:9200",

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 15 May 2014 05:58, <itbla...@gmail.com <javascript:>> wrote:

I have the following is showing up when I pull up my kibana dashboard:

http://192.168.10.25/#/dashboard

{{dashboard.current.title}}

When I tail my logs I see the following
2014/05/14 13:31:45 [error] 17152#0: *7 open()
"/var/www/kibana/app/diashboards/dashboard" failed (2: No such file or
directory), client: 192.168.11.53, server: 192.168.10.25, request: "GET
/app/diashboards/dashboard HTTP/1.1", host: "192.168.10.25"

I have been pulling my hair out over this, all help would be appreciated

This is my config.js

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5 
 * ==== elasticsearch 
 * 
 * The URL to your elasticsearch server. You almost certainly don't 
 * want +<a 

href="http://localhost:9200+">http://localhost:9200+ here. Even if Kibana
and Elasticsearch are on
* the same host. By default this will attempt to reach ES at the
same host you have
* kibana installed on. You probably want to set it to the FQDN of
your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",
/*elasticsearch: "http://"+window.location.hostname+":9200",

/** @scratch /configuration/config.js/5 
 * ==== default_route 
 * 
 * This is the default landing page when you don't specify a 

dashboard to load. You can specify
* files, scripts or saved dashboards here. For example, if you had
saved a dashboard called
* `WebLogs' to elasticsearch you might use:
*
* +default_route: '/dashboard/elasticsearch/WebLogs',+
*/
default_route : '/dashboard/file/default.json',

/** @scratch /configuration/config.js/5 
 * ==== kibana-int 
 * 
 * The default ES index to use for storing Kibana specific object 
 * such as stored dashboards 
 */ 
kibana_index: "kibana-int", 

/** @scratch /configuration/config.js/5 
 * ==== panel_name 
 * 
 * An array of panel modules available. Panels will only be loaded 

when they are defined in the
* dashboard, but this list is used in the "add panel" interface.
*/
panel_names: [
'histogram',
'map',
'pie',
'table',
'filtering',
'timepicker',
'text',
'hits',
'column',
'trends',
'bettermap',
'query',
'terms',
'stats',
'sparklines'
]
});
});

ngix (default)

/** @scratch /configuration/config.js/1

  • == Configuration
  • config.js is where you will find the core Kibana configuration. This
    file contains parameter that
  • must be set before kibana is run for the first time.
    */
    define(['settings'],
    function (Settings) {

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +http://localhost:9200+ here. Even if Kibana and 

Elasticsearch are on
* the same host. By default this will attempt to reach ES at the
same host you have
* kibana installed on. You probably want to set it to the FQDN of
your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9ed20394-75a7-43d4-9343-99b72eec8df8%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9ed20394-75a7-43d4-9343-99b72eec8df8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9a7f50ce-e15f-458b-846c-7565ac4a7dcf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I solved my problem. The documentation elasticsearch.org didn't work
(http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-http.html),
but it wasn't entirely their fault.

The options to use in your /etc/elasticsearch/elasticsearch.yml file if
you're using elasticsearch 1.4.x with kibana 3.x are:

http.cors.allow-origin: "/.*/"
http.cors.enabled: true

Source: http://stackoverflow.com/a/26884367/2015890

In the documentation on elasticsearch.org, it says to just use an asterisk,

  • , but that didn't work.

This didn't work:

http.cors.allow-origin: *

But this did:

http.cors.allow-origin: "*"

Figures.

Furthermore, I would like to get SSL to work, but I think this will have to do for now

On Monday, January 5, 2015 5:39:43 AM UTC-5, Eric wrote:

Here are the versions that I'm running:

Kibana version

Kibana 3.1.2-07bbd7e
eeded13255f154eaeceb4cf83105e4b4 kibana-3.1.2.tar.gz

Logstash version

[root@elk ~]# /opt/logstash/bin/logstash version
logstash 1.4.2-modified
1db9f0864ff4b89380b39c39bc419031 logstash-1.4.2-1_2c0f5a1.noarch.rpm

Elasticsearch version

[root@elk ~]# /usr/share/elasticsearch/bin/elasticsearch -v
Version: 1.4.2, Build: 927caff/2014-12-16T14:11:12Z, JVM: 1.7.0_51
6e2061f0734f9dbab263c1616701c1fe elasticsearch-1.4.2.noarch.rpm

OS

CentOS (CentOS-7.0-1406-x86_64-Everything.iso)
Installed packages: Basic Web Server + Development tools

Logstash runs fine. Elasticsearch runs fine. Kibana runs, but only shows
the screenshot shown below at, https://logstasht/#/dashboard

https://lh3.googleusercontent.com/-8mIiX5lKJ_U/VKpmMkRSftI/AAAAAAACYWM/v4LxHMzEAGI/s1600/kibana.png

On Wednesday, May 14, 2014 6:56:03 PM UTC-4, Mark Walkom wrote:

I think you have extra quotes causing a problem, try - elasticsearch: "
http://192.168.10.25:9200",

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 15 May 2014 05:58, itbla...@gmail.com wrote:

I have the following is showing up when I pull up my kibana dashboard:

http://192.168.10.25/#/dashboard

{{dashboard.current.title}}

When I tail my logs I see the following
2014/05/14 13:31:45 [error] 17152#0: *7 open()
"/var/www/kibana/app/diashboards/dashboard" failed (2: No such file or
directory), client: 192.168.11.53, server: 192.168.10.25, request: "GET
/app/diashboards/dashboard HTTP/1.1", host: "192.168.10.25"

I have been pulling my hair out over this, all help would be appreciated

This is my config.js

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5 
 * ==== elasticsearch 
 * 
 * The URL to your elasticsearch server. You almost certainly don't 
 * want +<a 

href="http://localhost:9200+">http://localhost:9200+ here. Even if Kibana
and Elasticsearch are on
* the same host. By default this will attempt to reach ES at the
same host you have
* kibana installed on. You probably want to set it to the FQDN of
your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",
/*elasticsearch: "http://"+window.location.hostname+":9200",

/** @scratch /configuration/config.js/5 
 * ==== default_route 
 * 
 * This is the default landing page when you don't specify a 

dashboard to load. You can specify
* files, scripts or saved dashboards here. For example, if you had
saved a dashboard called
* `WebLogs' to elasticsearch you might use:
*
* +default_route: '/dashboard/elasticsearch/WebLogs',+
*/
default_route : '/dashboard/file/default.json',

/** @scratch /configuration/config.js/5 
 * ==== kibana-int 
 * 
 * The default ES index to use for storing Kibana specific object 
 * such as stored dashboards 
 */ 
kibana_index: "kibana-int", 

/** @scratch /configuration/config.js/5 
 * ==== panel_name 
 * 
 * An array of panel modules available. Panels will only be loaded 

when they are defined in the
* dashboard, but this list is used in the "add panel" interface.
*/
panel_names: [
'histogram',
'map',
'pie',
'table',
'filtering',
'timepicker',
'text',
'hits',
'column',
'trends',
'bettermap',
'query',
'terms',
'stats',
'sparklines'
]
});
});

ngix (default)

/** @scratch /configuration/config.js/1

  • == Configuration
  • config.js is where you will find the core Kibana configuration. This
    file contains parameter that
  • must be set before kibana is run for the first time.
    */
    define(['settings'],
    function (Settings) {

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +http://localhost:9200+ here. Even if Kibana and 

Elasticsearch are on
* the same host. By default this will attempt to reach ES at the
same host you have
* kibana installed on. You probably want to set it to the FQDN of
your
* elasticsearch host
*/
elasticsearch: "http://"192.168.10.25":9200",

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9ed20394-75a7-43d4-9343-99b72eec8df8%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9ed20394-75a7-43d4-9343-99b72eec8df8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/219a13f6-b20c-4b5b-b764-19da39079190%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.