Elasticsearch with Kibana empty dashboard


(LinuxMan) #1

I have the following is showing up when I pull up my kibana dashboard:

http://192.168.10.25/#/dashboard

{{dashboard.current.title}}

When I tail my logs I see the following
2014/05/14 13:31:45 [error] 17152#0: *7 open() "/var/www/kibana/app/diashboards/dashboard" failed (2: No such file or directory), client: 192.168.11.53, server: 192.168.10.25, request: "GET /app/diashboards/dashboard HTTP/1.1", host: "192.168.10.25"

I have been pulling my hair out over this, all help would be appreciated

This is my config.js

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +http://localhost:9200+ here. Even if Kibana and Elasticsearch are on
 * the same host. By default this will attempt to reach ES at the same host you have
 * kibana installed on. You probably want to set it to the FQDN of your
 * elasticsearch host
 */
elasticsearch: "http://"192.168.10.25":9200",
/*elasticsearch: "http://"+window.location.hostname+":9200",

/** @scratch /configuration/config.js/5
 * ==== default_route
 *
 * This is the default landing page when you don't specify a dashboard to load. You can specify
 * files, scripts or saved dashboards here. For example, if you had saved a dashboard called
 * `WebLogs' to elasticsearch you might use:
 *
 * +default_route: '/dashboard/elasticsearch/WebLogs',+
 */
default_route     : '/dashboard/file/default.json',

/** @scratch /configuration/config.js/5
 * ==== kibana-int
 *
 * The default ES index to use for storing Kibana specific object
 * such as stored dashboards
 */
kibana_index: "kibana-int",

/** @scratch /configuration/config.js/5
 * ==== panel_name
 *
 * An array of panel modules available. Panels will only be loaded when they are defined in the
 * dashboard, but this list is used in the "add panel" interface.
 */
panel_names: [
  'histogram',
  'map',
  'pie',
  'table',
  'filtering',
  'timepicker',
  'text',
  'hits',
  'column',
  'trends',
  'bettermap',
  'query',
  'terms',
  'stats',
  'sparklines'
]

});
});

ngix default config

I have the following is showing up when I pull up my kibana dashboard:

http://192.168.10.25/#/dashboard

{{dashboard.current.title}}

When I tail my logs I see the following
2014/05/14 13:31:45 [error] 17152#0: *7 open() "/var/www/kibana/app/diashboards/dashboard" failed (2: No such file or directory), client: 192.168.11.53, server: 192.168.10.25, request: "GET /app/diashboards/dashboard HTTP/1.1", host: "192.168.10.25"

I have been pulling my hair out over this, all help would be appreciated

This is my config.js

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +<a href="http://localhost:9200+">http://localhost:9200+ here. Even if Kibana and Elasticsearch are on
 * the same host. By default this will attempt to reach ES at the same host you have
 * kibana installed on. You probably want to set it to the FQDN of your
 * elasticsearch host
 */
elasticsearch: "http://"192.168.10.25":9200",
/*elasticsearch: "http://"+window.location.hostname+":9200",

/** @scratch /configuration/config.js/5
 * ==== default_route
 *
 * This is the default landing page when you don't specify a dashboard to load. You can specify
 * files, scripts or saved dashboards here. For example, if you had saved a dashboard called
 * `WebLogs' to elasticsearch you might use:
 *
 * +default_route: '/dashboard/elasticsearch/WebLogs',+
 */
default_route     : '/dashboard/file/default.json',

/** @scratch /configuration/config.js/5
 * ==== kibana-int
 *
 * The default ES index to use for storing Kibana specific object
 * such as stored dashboards
 */
kibana_index: "kibana-int",

/** @scratch /configuration/config.js/5
 * ==== panel_name
 *
 * An array of panel modules available. Panels will only be loaded when they are defined in the
 * dashboard, but this list is used in the "add panel" interface.
 */
panel_names: [
  'histogram',
  'map',
  'pie',
  'table',
  'filtering',
  'timepicker',
  'text',
  'hits',
  'column',
  'trends',
  'bettermap',
  'query',
  'terms',
  'stats',
  'sparklines'
]

});
});

ngix (default)

/** @scratch /configuration/config.js/1

  • == Configuration
  • config.js is where you will find the core Kibana configuration. This file contains parameter that
  • must be set before kibana is run for the first time.
    */
    define(['settings'],
    function (Settings) {

/** @scratch /configuration/config.js/2

  • === Parameters
    */
    return new Settings({
/** @scratch /configuration/config.js/5
 * ==== elasticsearch
 *
 * The URL to your elasticsearch server. You almost certainly don't
 * want +http://localhost:9200+ here. Even if Kibana and Elasticsearch are on
 * the same host. By default this will attempt to reach ES at the same host you have
 * kibana installed on. You probably want to set it to the FQDN of your
 * elasticsearch host
 */
elasticsearch: "http://"192.168.10.25":9200",

(system) #2