Kibana ES incomptibility

I have installed ES v5.0.0-alpha4 and Kibana 4.5.2 on my windows 10 machine.

I get following error. [error][status][plugin:elasticsearch] Status changed from yellow to red - This version of Kibana requires Elasticsearch ^2.3.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v5.0.0-alpha4 @ (

I do have ES ^2.3. Not sure why Kibana is throwing error. Please help.


But... you just said you installed ES 5.0.0-alpha4, and then you said you're running ES 2.3. Which one is it?

I have ES v5.0.0-alpha4 .

Error messages talks about having version greater that 2.3.0. Which I already have.


The error message doesn't say "greater than 2.3.0". I'd assume they use the NPM versioning notation, in which case ^2.3.0 means "at least 2.3.0 but less than 3.0.0".

ES 5 is only compatible with KB 5.

Thanks a ton. This helped in resolving the issue.