Kibana geopoint is not working


(Peter) #1

Hello,

I am loading the information from my webserver to elasticsearch using packetbeats and when I am trying your dashboards on the geopoint visualization I am getting an error saying the following: Visualize: Expected geo_point type on field [client_location], but got [string]
When I am going to the settings to change the format of the client_location I have only two options to string, or default which is string. Is there any way to disable the string into false?


(Monica Sarbu) #2

The "client_location" field should be of type geo_point. Please make sure you have the packetbeat template loaded by following the steps: https://www.elastic.co/guide/en/beats/packetbeat/current/packetbeat-getting-started.html#packetbeat-template

It might be that geo location doesn't work from some reasons and the client_location is not set, having the value "". Can you please have a look and tell me what are the values of the "client_location" field? Thanks!


(system) #3