Kibana gets timed out

I am new to the elk stack I am running kibana in a VM with NAT I am able to ping the virtual machine from the host but when I navigate to http://VMipaddress:9200 it gets timed out.
Thanks in advance.

9200 is the Elasticsearch port - try 5601 (or the port you specified in your Kibana config file)

@flash1293 same result timed out.

do note that curl http://vmipaddress:5601/app/home on the vm works fine and gives the appropriate output.

Did you set server.host correctly in your config file? see https://www.elastic.co/guide/en/kibana/current/settings.html

This setting specifies the host of the back end server. To allow remote users to connect, set the value to the IP address or DNS name of the Kibana server

I have already set the sever.host value to 0.0.0.0 still the same timed out error

Please check whether your VM is reachable at all from the outside (besides Kibana). Maybe you have to allow the port to be accessible?

I am unable to connect to any port not even ssh and also not able to connect from other virtual machines.

Looks like this is an issue with your VM config in that case, not Kibana.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.