Kibana HeatMap Layer not displaying

I have tried with version 8.1.2 and upgraded to 8.1.3, I cannot get any heat maps to work. I do have it working for Documents Layer type without any problems.


Hi @Alessandro_Agnello Welcome to the community.

It is unclear what your issue.

Can you show your document types?

Show how you tried to configure heat maps?

Is there a time range for valid data?

Can you show us what does work for the document layer?

@Alessandro_Agnello, how are running Elasticsearch? In cloud or from a download. There is a bug in 8.1 that prevents vector tiles from loading in on-prem instances (and in 8.1, heatmap layer implementation was switched to using vector tiles.). The work around is setting http.compression: true in Elasticsearch.yml.

1 Like

@Nathan_Reese I am running via a Docker using Docker-Compose running a standard config. I will say the vector tiles are a great combination use of both Heat Maps and detailed values.


Did the compression setting work for you? ( Funny! I should have remembered that since I was on the last discussion on this and helped identify the bug :slight_smile: )

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.