Kibana - IIS 7.5

I was able to get Kibana setup on my localhost and did a generic entry to
allow everything into the elasticsearch.yml

http.cors.allow-origin: "/.*/"

Now I'm trying to getting it to run on my remote server running IIS 7.5 on
port 8080.

The page loads but only the top bar loads and nothing else any ideas?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/31402e52-0b96-4f2a-900a-d7f09bf62774%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

On Monday, January 26, 2015 at 14:58 CET,
GWired garrettcjohnson@gmail.com wrote:

I was able to get Kibana setup on my localhost and did a generic entry
to allow everything into the elasticsearch.yml
http.cors.allow-origin: "/.*/"
Now I'm trying to getting it to run on my remote server running IIS
7.5 on port 8080.
The page loads but only the top bar loads and nothing else any ideas?

Did you also enable CORS by setting http.cors.enabled to true?


http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-http.html

--
Magnus Bäck | Software Engineer, Development Tools
magnus.back@sonymobile.com | Sony Mobile Communications

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/20150126144857.GA18395%40seldlx20533.corpusers.net.
For more options, visit https://groups.google.com/d/optout.

You may want to give this a try:

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Lucene.NET committer and PMC member

On Mon, Jan 26, 2015 at 3:58 PM, GWired garrettcjohnson@gmail.com wrote:

I was able to get Kibana setup on my localhost and did a generic entry to
allow everything into the elasticsearch.yml

http.cors.allow-origin: "/.*/"

Now I'm trying to getting it to run on my remote server running IIS 7.5 on
port 8080.

The page loads but only the top bar loads and nothing else any ideas?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/31402e52-0b96-4f2a-900a-d7f09bf62774%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/31402e52-0b96-4f2a-900a-d7f09bf62774%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHTr4ZsZSWdjC6RwLFgm2p8Q3Y_kSJT6W1wVw8SQ7U-MeJtjqA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Yes,

It works when I'm on my localhost serving it to me connected to a remote
elasticsearch. It just isn't working when I'm serving it from a dedicated
Windows 2008 web server connected to the same remote elasticsearch.

Config Working:

Desktop: IIS 8 installed on Windows 8.1 - Kibana Installed Localhost
Server: abc.mydomain.com:9200, Elasticsearch 1.4.2
Elastic Search yml has

http.cors.enabled: true
http.cors.allow-origin: "/.*/"

Config Not Working:
Kibana Server: IIS 7.5 installed on Server 2008R2 - Kibana Installed on
port 8080
Elasticsearch Server: exactly the same as above

When elasticsearch was cors info was incorrect it actually gave an error
message. Now it is just launching partially, it's not giving any errors.
Which is very strange.

No Errors in the eventlog of the Kibana server.

Garrett

On Monday, January 26, 2015 at 9:49:16 AM UTC-5, Magnus Bäck wrote:

On Monday, January 26, 2015 at 14:58 CET,
GWired <garrett...@gmail.com <javascript:>> wrote:

I was able to get Kibana setup on my localhost and did a generic entry
to allow everything into the elasticsearch.yml
http.cors.allow-origin: "/.*/"
Now I'm trying to getting it to run on my remote server running IIS
7.5 on port 8080.
The page loads but only the top bar loads and nothing else any ideas?

Did you also enable CORS by setting http.cors.enabled to true?

http://stackoverflow.com/questions/26828099/kibana-returns-connection-failed

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-http.html

--
Magnus Bäck | Software Engineer, Development Tools
magnu...@sonymobile.com <javascript:> | Sony Mobile Communications

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/77582986-b897-411f-90bd-6a627bdd3049%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Have you added the .json MIME type for the site in IIS?

On Monday, January 26, 2015 at 3:46:44 PM UTC, GWired wrote:

Yes,

It works when I'm on my localhost serving it to me connected to a remote
elasticsearch. It just isn't working when I'm serving it from a dedicated
Windows 2008 web server connected to the same remote elasticsearch.

Config Working:

Desktop: IIS 8 installed on Windows 8.1 - Kibana Installed Localhost
Server: abc.mydomain.com:9200, Elasticsearch 1.4.2
Elastic Search yml has

http.cors.enabled: true
http.cors.allow-origin: "/.*/"

Config Not Working:
Kibana Server: IIS 7.5 installed on Server 2008R2 - Kibana Installed on
port 8080
Elasticsearch Server: exactly the same as above

When elasticsearch was cors info was incorrect it actually gave an error
message. Now it is just launching partially, it's not giving any errors.
Which is very strange.

No Errors in the eventlog of the Kibana server.

Garrett

On Monday, January 26, 2015 at 9:49:16 AM UTC-5, Magnus Bäck wrote:

On Monday, January 26, 2015 at 14:58 CET,
GWired garrett...@gmail.com wrote:

I was able to get Kibana setup on my localhost and did a generic entry
to allow everything into the elasticsearch.yml
http.cors.allow-origin: "/.*/"
Now I'm trying to getting it to run on my remote server running IIS
7.5 on port 8080.
The page loads but only the top bar loads and nothing else any ideas?

Did you also enable CORS by setting http.cors.enabled to true?

http://stackoverflow.com/questions/26828099/kibana-returns-connection-failed

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-http.html

--
Magnus Bäck | Software Engineer, Development Tools
magnu...@sonymobile.com | Sony Mobile Communications

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0b66fb2-34c6-43e7-9dc7-e5782400bed1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

That was it, I guess Windows 8 has it out of the box.

On Tuesday, January 27, 2015 at 3:31:28 AM UTC-5, Akshay Davis wrote:

Have you added the .json MIME type for the site in IIS?

On Monday, January 26, 2015 at 3:46:44 PM UTC, GWired wrote:

Yes,

It works when I'm on my localhost serving it to me connected to a remote
elasticsearch. It just isn't working when I'm serving it from a dedicated
Windows 2008 web server connected to the same remote elasticsearch.

Config Working:

Desktop: IIS 8 installed on Windows 8.1 - Kibana Installed Localhost
Server: abc.mydomain.com:9200, Elasticsearch 1.4.2
Elastic Search yml has

http.cors.enabled: true
http.cors.allow-origin: "/.*/"

Config Not Working:
Kibana Server: IIS 7.5 installed on Server 2008R2 - Kibana Installed on
port 8080
Elasticsearch Server: exactly the same as above

When elasticsearch was cors info was incorrect it actually gave an error
message. Now it is just launching partially, it's not giving any errors.
Which is very strange.

No Errors in the eventlog of the Kibana server.

Garrett

On Monday, January 26, 2015 at 9:49:16 AM UTC-5, Magnus Bäck wrote:

On Monday, January 26, 2015 at 14:58 CET,
GWired garrett...@gmail.com wrote:

I was able to get Kibana setup on my localhost and did a generic entry
to allow everything into the elasticsearch.yml
http.cors.allow-origin: "/.*/"
Now I'm trying to getting it to run on my remote server running IIS
7.5 on port 8080.
The page loads but only the top bar loads and nothing else any ideas?

Did you also enable CORS by setting http.cors.enabled to true?

http://stackoverflow.com/questions/26828099/kibana-returns-connection-failed

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-http.html

--
Magnus Bäck | Software Engineer, Development Tools
magnu...@sonymobile.com | Sony Mobile Communications

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2bc3973c-2291-4f3d-a02c-f49824ede2c5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.