Kibana Index patter issue with alias

I am working on existing index pattern where field alias does not work when used as a part of filter.
I have tried below things so far

  1. Index pattern refresh
  2. try to fetch the query sent from Kibana and it has [object object] in place of field name which is causing an error
  3. created new index pattern where the same field works perfectly fine
  4. Field works on search box but does not work as a filter

Please help!

@ananta05 I'd like to reproduce this locally - which version of the stack are you running?

I use 6.8

I think it wont be easy to reproduce. Any specific area I can check to solve it?

Can you share the query or error message you're seeing?

Here is the query kibana fires when field alias is used as filter. It is captured from inspect

@ananta05

Which revision of 6.8 are you running? I tried this under 6.8.14 and it worked fine. Perhaps it has to do with the mapping of the particular field you're attempting to use.

--Matt