Kibana Keystore


(delly) #1

Hi,

I created a keystore in kibana to store the credentials for connecting kibana to ElasticSearch.

But I received the error when restart the Kibana. Anyone encountered and how to resolved this?

log [05:08:57.786] [fatal] "elasticsearch_password" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.
FATAL "elasticsearch_password" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.


(Peter Pisljar) #2

can you provide more details on the steps you took ?

i guess you tried to follow this: https://www.elastic.co/guide/en/kibana/current/secure-settings.html ?


(delly) #3

yes. Step by step follow that link.

This is how my kibana.yml config file looks like:
# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
elasticsearch.username: "kibana"
elasticsearch.password: ${ES_PWD}

but when I restart the kibana, I received error:
log [04:07:50.215] [fatal] "ES_PWD" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.
FATAL "ES_PWD" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.

Pls help?


(delly) #4

okay, managed to get it work.

The name of the key in the keystore has to be the same as in the kibana.yml

like this:
elasticsearch.password: ${elasticsearch.password}


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.