Kibana Locale

I'm trying to set my Kibana locale to en-za in order to get the correct currency format. In the format:number:defaultLocale dropdown in the Kibana GUI I don't see "en-za" listed, but it is in the /usr/share/kibana/node_modules/numeral/locales.js file. How do I select it?

Looks like that list is populated from https://github.com/elastic/numeral-js/tree/kibana-fork/languages and passed into the advanced settings at https://github.com/elastic/kibana/blob/7.4/src/legacy/core_plugins/kibana/ui_setting_defaults.js#L775

Would you mind creating an issue at https://github.com/elastic/kibana/issues/new?template=Feature_request.md to add en-za to https://github.com/elastic/numeral-js?