Kibana Monitoring Elasticsearch nodes doesn't show CPU usage


(Jaqui) #1

I'm having an issue with CPU stats shown for Elasticsearch nodes in Kibana Monitoring.

The problem is that CPU Usage is always 0.

Kibana and Elasticsearch both run as docker containers and version 5.3.2.

Checking the kibana requests using the browser's developer tools I can see that the request to /api/monitoring/v1/clusters/uuid/elasticsearch/nodes returns:

            "node_cgroup_quota": {
                "metric": {
                    "app": "elasticsearch",
                    "field": "node_stats.process.cpu.percent",
                    "label": "Cgroup CPU Utilization",
                    "title": "CPU Utilization",
                    "description": "CPU Usage time compared to the CPU quota shown in percentage. If CPU quotas are not set, then the OS level CPU usage in percentage is shown.",
                    "units": "%",
                    "format": "0,0.[00]"
                },
                "min": null,
                "max": null,
                "slope": null
            },

The weird thing is that if I go to a node's detail page it shows cpu usage:

Is there any configuration I'm missing? This was a 5.1.1 cluster that was upgraded to 5.3.2, and when it was 5.1.1 cpu stats were showing fine.

Thanks!


(Chris Earle) #2

Hi @jaquisar1,

The fact that the node list is showing the CPU Throttling suggests that someone has enabled the Monitoring UI Container settings:

https://www.elastic.co/guide/en/x-pack/current/monitoring-settings.html#monitoring-ui-cgroup-settings

Given that there is no throttling (all zeroes), I assume these are not running in containers, so this setting should be turned off in the kibana.yml, which is its default value (so it can be removed):

xpack.monitoring.ui.container.elasticsearch.enabled: false

(Jaqui) #3

Thank you @pickypg!! You pointed me in the right direction.

At first I was running Kibana with a custom docker image and then I moved to docker.elastic.co/kibana/kibana image, the new image has the setting you mentioned in true (https://www.elastic.co/guide/en/kibana/current/_configuring_kibana_on_docker.html#_docker_defaults).

In order to disable it I added the XPACK_MONITORING_UI_CONTAINER_ELASTICSEARCH_ENABLED with false.

Thanks!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.