Kibana shows 0 CPU usage if cgroups stats enabled


#1

Hello. If I switch Kibana to cgroup stats with "xpack.monitoring.ui.container.elasticsearch.enabled: true" config, I see just 0% CPU usage for all elasticsearch nodes. Kibana, Logstash and Elasticsearch are running in docker containers, cgroup path overrides are in place for kibana (--cpu.cgroup.path.override=/ --cpuacct.cgroup.path.override=/) and elasticsearch (es.cgroups.hierarchy.override=/). Am I missing some config?


(Lee Drengenberg) #2

What version of the stack are you on?


#3

5.5.0


(Lee Drengenberg) #4

If you run this in your Kibana Dev Tools > Console;
GET .monitoring-es-*/_mapping

and then see if that mapping includes cfs_quota_micros


#5

Yes, there is:

...
"os": {
                "properties": {
                  "cgroup": {
                    "properties": {
                      "cpu": {
                        "properties": {
                          "cfs_quota_micros": {
                            "type": "long"
                          },
...

(Chris Earle) #6

Hi @vb4t,

Are you using any type of throttling within the ES containers? If not, then I suggest just disabling this setting (going back to the default) and using the process-level CPU percentage.

We are in the middle of updating our documentation, so this should hopefully be clearer in the future, but unless you have a quota and therefore throttle the process, then there is no advantage to monitoring Cgroup CPU usage.

Hope that helps,
Chris


#7

Hello. Currently I do not use throttling. But in the near future I want to use it.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.