Kibana not loading properly

I am using Kibana 7.2.0 and getting the following result while accessing
http://localhost:5601

I am getting the following error in kibana.bat:

log [04:06:22.223] [info][status][plugin:reporting@7.2.0] Status changed from uninitialized to green - Ready
log [04:06:22.901] [info][listening] Server running at http://localhost:5601
log [04:06:22.940] [info][status][plugin:spaces@7.2.0] Status changed from yellow to green - Ready
error [04:06:44.097] Error: Failed to hash file: ENOENT: no such file or directory, read
error [04:06:44.093] Error: Failed to hash file: ENOENT: no such file or directory, read

I have reinstalled Kibana but the issue still persist.

Hi @Arshdeep_Sandhu
Could you share the content of kibana.yml file?

Hi dgonzalezp,

No changes have been made to kibana.yml. All lines are comments.

Example:
# Kibana is served by a back end server. This setting specifies the port to use.
#server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
#server.host: "localhost"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

Not all the lines should be comments. The next lines must be uncommented:

server.port: 5601
server.host: "0.0.0.0"
elasticsearch.hosts: ["http://localhost:9200"]

Check if the lines are correct and without comment in your kibana.yml file

I have uncommented the following as mentioned but same error persist.

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "0.0.0.0"
# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["http://localhost:9200"]

Have you restart the kibana service after the changes?

Yes. I restarted Kibana.

Is there any other way to go about this?

Hi @Arshdeep_Sandhu.

Please Try to copy and paste in your kibana.yml

Kibana is served by a back end server. This setting specifies the port to use.

server.port: 5601

Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

The default is 'localhost', which usually means remote machines will not be able to connect.

To allow connections from remote users, set this parameter to a non-loopback address.

server.host: "localhost"

Enables you to specify a path to mount Kibana at if you are running behind a proxy.

Use the server.rewriteBasePath setting to tell Kibana if it should remove the basePath

from requests it receives, and to prevent a deprecation warning at startup.

This setting cannot end in a slash.

#server.basePath: ""

Specifies whether Kibana should rewrite requests that are prefixed with

server.basePath or require that they are rewritten by your reverse proxy.

This setting was effectively always false before Kibana 6.3 and will

default to true starting in Kibana 7.0.

#server.rewriteBasePath: false

The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes.

server.name: "localhost"

The URLs of the Elasticsearch instances to use for all your queries.

elasticsearch.hosts: ["http://localhost:9200"]

When this setting's value is true Kibana uses the hostname specified in the server.host

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

#elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations and

dashboards. Kibana creates a new index if the index doesn't already exist.

#kibana.index: ".kibana"

The default application to load.

#kibana.defaultAppId: "home"

If your Elasticsearch is protected with basic authentication, these settings provide

the username and password that the Kibana server uses to perform maintenance on the Kibana

index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

is proxied through the Kibana server.

elasticsearch.username: "elastic"
elasticsearch.password: "Hadoop"

Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.

These settings enable SSL for outgoing requests from the Kibana server to the browser.

#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

Optional settings that provide the paths to the PEM-format SSL certificate and key files.

These files validate that your Elasticsearch backend uses the same key files.

#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

Optional setting that enables you to specify a path to the PEM file for the certificate

authority for your Elasticsearch instance.

#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

To disregard the validity of SSL certificates, change this setting's value to 'none'.

#elasticsearch.ssl.verificationMode: full

Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of

the elasticsearch.requestTimeout setting.

#elasticsearch.pingTimeout: 1500

Time in milliseconds to wait for responses from the back end or Elasticsearch. This value

must be a positive integer.

#elasticsearch.requestTimeout: 30000

List of Kibana client-side headers to send to Elasticsearch. To send no client-side

headers, set this value to (an empty list).

#elasticsearch.requestHeadersWhitelist: [ authorization ]

Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten

by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.

#elasticsearch.customHeaders: {}

Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.

#elasticsearch.shardTimeout: 30000

Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.

#elasticsearch.startupTimeout: 5000

Logs queries sent to Elasticsearch. Requires logging.verbose set to true.

elasticsearch.logQueries: false

Specifies the path where Kibana creates the process ID file.

#pid.file: /var/run/kibana.pid

Enables you specify a file where Kibana stores log output.

logging.dest: stdout

Set the value of this setting to true to suppress all logging output.

logging.silent: false

Set the value of this setting to true to suppress all logging output other than error messages.

#logging.quiet: false

Set the value of this setting to true to log all events, including system usage information

and all requests.

#logging.verbose: false

Set the interval in milliseconds to sample system and process performance

metrics. Minimum is 100ms. Defaults to 5000.

#ops.interval: 5000

Specifies locale to be used for all localizable strings, dates and number formats.

#i18n.locale: "en"

Note:-please try to stop all services like elastic and kibana then restart.

I will try this then.

HI @rameshkr1994
This config did not work either. Same error is occuring again.
In another system, Kibana.bat of version 6.6.0 is working fine while here
Failed to hash file: ENOENT: no such file or directory, read
error is recurring.

Why is such scenario occuring, please clarify.

Do you have compatible versions for ELK??
Try older but same versions for all the three stacks.

I hope it will work!!

I will try with the older version.

Hi @Arshdeep_Sandhu.

make sure your ELK version match with each other.

like i am using latest:-

elasticsearch-7.1.1
logstash-7.1.1
kibana-7.1.1

Hi @Arshdeep_Sandhu.

this issue comes when kibana.yml path is not matching pattern with

  • pid.file: /var/run/kibana.pid
    -second option you comment this part and try.
    -kibana.yml file config is mismatch with some value

HI @rameshkr1994
I am using elasticsearch-7.2.0
logstash-7.2.0
kibana-7.2.0
I have unzipped all of them again and still kibana is not working.

-second option you comment this part and try.

Comment which part and where to find kibana.pid?

Hi @Arshdeep_Sandhu.

check if your ES is running on localhost then no need to modify anything from kibana.yml.

if you are using windows machine just go to bin folder of kibana and start IT before run this check ES is running and Up.

LIKE:- kibana.bat hit enter

It will work.

I don't know what kind of config your are doing ..

for testing purpose you can use default all setting including kibana,ES.

I did this multiple times so please check carefully.

Hi

Elasticsearch is up and running.

I have not made any configuration changes in Kibana.yml file and running with default settings only. But I still get the same message only.

Error: Failed to hash file: ENOENT: no such file or directory, read

I have downloaded fresh copy of Kibana from Elasticsearch website as well but it does not seem to work.

Please help.

Thanks

I have reformatted the system and installed new version of Elastic Search.
Everything is working fine now.