Kibana on localhost still requires an active Internet connection?


#1

I'm new and trying to install Elasticsearch and Kibana on the same Windows 10 computer without an active Internet connection. Elasticsearch seems to work OK, but Kibana can't find Elasticsearch on the same host without an active Internet connection. Is this correct? If so, why should the Internet be needed if both Elasticsearch and Kibana are on the same host, and both configured to use "localhost"?

Below is output from Kibana showing that it cannot connect to Elasticsearch, and then at the bottom an Internet connection is activated, and Kibana connects to Elasticsearch. Any thoughts?

C:\kibana>bin\kibana
log [10:59:13.981] [info][status][plugin:kibana] Status changed from uninitialized to green - Ready
log [10:59:14.012] [info][status][plugin:elasticsearch] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [10:59:14.028] [info][status][plugin:kbn_vislib_vis_types] Status changed from uninitialized to green - Ready
log [10:59:14.028] [error][elasticsearch] Request error, retrying -- getaddrinfo ENOENT localhost:9200
log [10:59:14.028] [info][status][plugin:markdown_vis] Status changed from uninitialized to green - Ready
log [10:59:14.043] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:14.043] [warning][elasticsearch] No living connections
log [10:59:14.043] [error][status][plugin:elasticsearch] Status changed from yellow to red - Unable to connect to Elasticsearch at http://localhost:9200.
log [10:59:14.043] [info][status][plugin:metric_vis] Status changed from uninitialized to green - Ready
log [10:59:14.059] [info][status][plugin:spyModes] Status changed from uninitialized to green - Ready
log [10:59:14.059] [info][status][plugin:statusPage] Status changed from uninitialized to green - Ready
log [10:59:14.059] [info][status][plugin:table_vis] Status changed from uninitialized to green - Ready
log [10:59:14.074] [info][listening] Server running at http://localhost:5601
log [10:59:16.552] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:16.552] [warning][elasticsearch] No living connections
log [10:59:19.051] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:19.051] [warning][elasticsearch] No living connections
log [10:59:21.551] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:21.551] [warning][elasticsearch] No living connections
log [10:59:24.059] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:24.059] [warning][elasticsearch] No living connections
log [10:59:26.560] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:26.560] [warning][elasticsearch] No living connections
log [10:59:29.071] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:29.071] [warning][elasticsearch] No living connections
log [10:59:31.578] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:31.578] [warning][elasticsearch] No living connections
log [10:59:34.090] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:34.090] [warning][elasticsearch] No living connections
log [10:59:36.597] [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
log [10:59:36.597] [warning][elasticsearch] No living connections
log [10:59:39.183] [info][status][plugin:elasticsearch] Status changed from red to green - Kibana index ready


(Court Ewing) #2

That's a strange one! If your internet connection is disabled, can you access http://localhost:9200 in your browser?


#3

Yes, everything I do to Elasticsearch seems to operate normally. http://localhost:9200 returns the expected json record.

I've played with it a bit, and it is very reproducible. If the Internet connection is disabled, you get "no living connections" from Kibana. Activate an Internet connection, Kibana works fine. As I said, this is under Windows 10. I've not tried it under Linux yet, however if this were a Windows TCP/IP stack issue, I would expect http://localhost:9200 from a browser to fail also.

An interesting problem, but if anyone wants to air-gap sensitive data, this might be an issue.


(Court Ewing) #4

That is so strange... I definitely run Kibana all of the time without an internet connection (albeit not on Windows). Complete shot in the dark, but does it work if you point to an IP instead of a hostname? Something like:

elasticsearch.url: "http://127.0.0.1:9200"


#5

Yes, http://127.0.0.1:9200 works fine. I'm assuming when you say you run without an Internet connection, you are running under Linux? My Linux box is in a different location, so if you've already done that test, I don't need to repeat it. Strange...


(Court Ewing) #6

Correct, I've run it on both linux and darwin without internet connections without issue. I wonder if Windows 10 is doing some sort of forced DNS lookup even when using localhost...


#7

I have kibana running on two windows 10 machines locally.
(2 different projects).
One of them decided two days ago that it can't reach elastic url localhost:9200 unless the internet connection is active.
The other one still connects without internet connection!
Any clue?


#8

Hi @johncst @Court
I still have this problem.
in the configure yml file of kibana I changed the url to 127.0.0.1 ,
however the problem persists.
Did you figure out how to solve it?


#9

Any solution please.


#10

I have not solved the problem. I had to get moving on the remaining ELK work, so I simply connected to the Internet to get Kibana working. I do plan to get back to this issue. Sorry I couldn't be of more immediate help.


#11

Any solution here? I have the latest ES and Kibana 5.1.2 and have exactly the same issue. I am on the go and there is no internet in the plane or in some airports.
I run on latest Windows 10 x64


(Ocean) #12

I am facing same problem; anyone found solution yet. I cannot connect to internet while on the go with laptop.


(prakash) #13

I am also getting the same issue as mentioned above.. could you please give the solution..


(Court Ewing) #14

I'm not sure what the issue is, exactly, but you should be able to get Kibana running locally in that setup by setting the following in your kibana.yml:

elasticsearch.url: "http://127.0.0.1:9200"

(prakash) #15

Thanks for your response. I will check and let you know.