Kibana RAM allocation

Hi there

Despite of 8G RAM, my Kibana uses only 1G of RAM...
How can I allocate more RAM to Kibana?

What should I write in kibana.yml to determine more RAM for Kibana?

Hello Farid,

Did you have a look at this Kibana documentation: Use Kibana in a production environment | Kibana Guide [7.11] | Elastic ?

Kibana has a default maximum memory limit of 1.4 GB, and in most cases, we recommend leaving this unconfigured. In some scenarios, such as large reporting jobs, it may make sense to tweak limits to meet more specific requirements.

You can modify this limit by setting --max-old-space-size in the node.options config file that can be found inside kibana/config folder or any other configured with the environment variable KBN_PATH_CONF (for example in debian based system would be /etc/kibana ).
The option accepts a limit in MB:

--max-old-space-size=2048

Best regards
Wolfram

Thanks for your response, but unfortunately I can not find any node.options that can be found inside kibana/config...!!

I have only a config file in the path /etc/kibana which is kibana.yml

Could you please explain more where is node.options ?

Hello Farid,

Maybe you should create the file in /etc/kibana. I am using the zipped version of kibana which contains the file but it is empty containing only comments:

## Node command line options
## See `node --help` and `node --v8-options` for available options
## Please note you should specify one option per line

## max size of old space in megabytes
#--max-old-space-size=4096

Best regards
Wolfram

Great... Thank you so much.
And if I create a file node.options and write --max-old-space-size=4096 that is enough?
Then restart the kibana?
Do I need to do something else?!?

I haven't tried it but I think this would be all.

1 Like

Thank you so much...

You can also edit Kibana.bat or kibana.sh script that run kibana ?
There is an option there for that NODE_OPTIONS
node.options i guess is only in latest versions of Kibana

Thanks for your response
Unfortunately my Kibana is not the latest version...
So how can I edit Kibana.bat or kibana.sh ?

I have already built node.options and set --max-old-space-size=4096 but I want to check is it working or not!!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.