Set Kibana Memory

in kibana 7.17.7, How I can set the Memory for kibana, I edited node.options and set to --max-old-space-size=8192 but when i go "stack monitoring", i found that kibana still showing under "Memory Usage :1.9 GB / 4.0 GB"

Welcome to the community kaismax

Have you tried this?

1 Like

I had the same issue a couple of months ago, even opened a ticket with the support but they couldn't reproduce the issue, so there was no solution.

What I needed to do when I was using 7.17 was to edit the Kibana startup script and put the setting directly on the script, the --max-old-space-size was hardcoded in the startup script.

1 Like

Wow Worked..... thanks @Rios

1 Like

Yeah, this was my first solution when I had this issue, changed the NODE_OPTIONS into:

NODE_OPTIONS="--no-warnings --max-http-header-size=65536 --tls-min-v1.0 $KBN_NODE_OPTS $NODE_OPTIONS" NODE_ENV=production exec "${NODE}" --max-old-space-size=4096 "${DIR}/src/cli/dist" ${@}

After a couple more of tests, this also worked:

NODE_OPTIONS="--no-warnings --max-http-header-size=65536 --tls-min-v1.0 $NODE_OPTIONS" NODE_ENV=production exec "${NODE}" $KBN_NODE_OPTS "${DIR}/src/cli/dist" ${@}

Just moved the $KBN_NODE_OPTS then it correctly sourced the value from the node.options file.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.