Kibana Request Timeout after 3000ms


(Ammo) #1

Hi There,

i am using Kibana with Elasticsearch, Filebeat and Logstash.
Currently i am running verison 5.x and i want to upgrade to version 6.x
Unfortunately, after installing xpack plugin in kibana and elasticsearch i am getting this error messages:

{"type":"log","@timestamp":"2018-02-15T14:24:11Z","tags":["status","plugin:tilemap@5.6.7","error"],"pid":7613,"state":"red","message":"Status changed from green to red - Request Timeout after 3000ms","prevState":"green","prevMsg":"Ready"}
{"type":"log","@timestamp":"2018-02-15T14:24:11Z","tags":["status","plugin:watcher@5.6.7","error"],"pid":7613,"state":"red","message":"Status changed from green to red - Request Timeout after 3000ms","prevState":"green","prevMsg":"Ready"}
{"type":"log","@timestamp":"2018-02-15T14:24:11Z","tags":["status","plugin:upgrade@5.6.7","error"],"pid":7613,"state":"red","message":"Status changed from green to red - Request Timeout after 3000ms","prevState":"green","prevMsg":"Ready"}

Did i something wrong?
Regards, Ahmet

EDIT: Here is a picture what kibana looks like after installing xpack:

EDIT2: Sometimes everything seems to work and monitoring is all green. After i tried to do a cluster checkup in the upgrade assistant i got this:


(Bill McConaghy) #2

Can you confirm that you have installed xpack correctly in elasticsearch ? I have seen this before when xpack is not installed there.


(Ammo) #3

Hi Bill,

this is what i did for installing xpack:

cd /usr/share/kibana/
bin/kibana-plugin install x-pack
cd /usr/share/elasticserach/
bin/elasticsearch-plugin install x-pack

bin/elasticsearch-plugin list
x-pack


(Ammo) #4

Hi Bill,
this has been solved by adjusting the min and max JVM heap valuesin /etc/elasticsearch/jvm.options to:

-Xms4g
-Xmx4g

They were set to 2g.
Regards, Ahmet


(Bill McConaghy) #5

Ahh yes, OOM issues would definitely cause slow/no response. Glad you have fixed your issue.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.