Kibana SAML Session TimeOut

I have SAML configured between a hosted Kibana cluster, ElasticSearch Cloud, and AzureAD. Authentication works perfect but, if a user has a dashboard open and set to auto-refresh, they are logged out after 20 minutes.

I've set "idp.use_single_logout: False" so it no longer logs them out of AzureAD, but they are still redirected to the Kibana home page every 20 minutes.

I tried to modify the token timeout setting in ES but get an error "'': is not allowed"

How can I disable session timeout for SSO users?

I have moved this to the Kibana forum.

Hi Tim,

Thank you but I suspect this has to do with the setting in ElasticSearch as described in the documentation. "The access token is a short-lived token. By default, it expires after 20 minutes but it can be configured to last a maximum of 1 hour.".

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.