Kibana server is not ready yet - 6.3 to 6.5


I have tried upgrade of Kibana from 6.3 to 6.5 and am getting "Kibana server is not ready yet" on Kibana.

I have also tried removing the .kibana index but still the error persisit. Any help in here will be much appreciated.

Below Error found on the kibana logs.

{"type":"log","@timestamp":"2018-12-29T06:37:00Z","tags":["debug","legacy","proxy"],"pid":27677,"message":"Event is being forwarded: clientError"}
{"type":"error","@timestamp":"2018-12-29T06:37:00Z","tags":["connection","client","error"],"pid":27677,"level":"error","error":{"message":"socket hang up","name":"Error","stack":"Error: socket hang up\n at TLSSocket. (_tls_wrap.js:890:25)\n at emitOne (events.js:121:20)\n at TLSSocket.emit (events.js:211:7)\n at _handle.close (net.js:561:12)\n at Socket.done (_tls_wrap.js:360:7)\n at Object.onceWrapper (events.js:315:30)\n at emitOne (events.js:116:13)\n at Socket.emit (events.js:211:7)\n at TCP._handle.close [as _onclose] (net.js:561:12)","code":"ECONNRESET"},"message":"socket hang up"}


Did you also upgrade Elasticsearch to 6.5? How are you securing the stack? Can you share your config?

Hello Christian,

It is resolved!!

I had done an apt upgrade. Initially it was not even creating the .kibana index. I tried stopping my apt instance of the kibana and brought up the downloaded tar version in one of the elastic nodes with basic config file.It was able to connect successfully to the elastic search with .kibana1 index created.

Later I could see that apt kibana instance was starting but experiencing the OOM error at optimizing bundles. Thanks to the new feature I was able to add the NODE_OPTION to the default directory.

$ cat /etc/default/kibana | grep -i NODE_OPTIONS

Thanks again for your time..


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.