Kibana Server is not ready yet after deletion of indeces inside /var/lib/nodes/0/indeces

Hello,

I'm unable to access my Kibana Dashboard after deleting some of the indeces directory inside /var/lib/nodes/0/indeces/. Before this I had an error regarding Low disk space that's preventing the elasticsearch to start that's why I decided to delete the indeces.

Elasticsearch service finally started but Kibana Dashboard won't show up.

Tried opening the <IP ADDRESS>:9200 on browser but I'm unable to enter using the credential we have used before.

Tried to generate the password using /usr/share/elasticsearch/bin/elasticsearch-setup-passwords auto but i'm getting the error below.

[@@@@@@]#  /usr/share/elasticsearch/bin/elasticsearch-setup-passwords auto

Failed to authenticate user 'elastic' against http://<IP ADDRESS>:9200/_security/_authenticate?pretty
Possible causes include:
 * The password for the 'elastic' user has already been changed on this cluster
 * Your elasticsearch node is running against a different keystore
   This tool used the keystore at /etc/elasticsearch/elasticsearch.keystore


ERROR: Failed to verify bootstrap password

Hope someone can help me fix this. Thank you soooo much!

See these docs:

WARNING: Don’t modify anything within the data directory or run processes that might interfere with its contents. If something other than Elasticsearch modifies the contents of the data directory, then Elasticsearch may fail, reporting corruption or other data inconsistencies, or may appear to work correctly having silently lost some of your data.

You probably need to start again with an empty node and let Elasticsearch recover the missing shards from the other nodes in your cluster.

Hi @DavidTurner , Issue has been resolved. You're correct I had to delete the nodes directory inside the /var/lib/elasticsearch/. Just a follow-up question, would you be able to provide what are the files need to be delete and where just so we cant let this happen again? Thank you.

The rule is simple: do not ever delete anything from inside the data path.