Kibana Server time and PC time doesn't match

Hi all,

I have a strange problem. Basically, when I run Kibana Server, its server time and my PC's local time doesn't match. The problem has started appearing recently -- not sure but maybe, just after daylight saving time 2017 in the UK last weekend.

I realised that after seeing my documents stored at wrong timestamp via Kibana. When I search them directly through ES APIs, timestamp looks correct. However, in Kabana, timestamp looks one hour ahead. For example, a document stored at 09:00.00 looks 10:00:00. Therefore, you cannot retrieve it using "last 15 minutes" pre-defined time range.

I have checked Kibana -> Advanced Settings -> dateFormat:tz (Default: Browser)

I replaced the default value (Browser) with "UCT", and this allowed me to see the correct timestamp at Kibana. But, the time range feature (e.g. discover data 'last 15 minutes' etc.) still doesn't work. Also, I don't understand why I should play with advanced settings. Because everything was perfect by default values before.

Note: I tried and reproduced the same problem using both ES/Kibana 5.2.0 and 5.3.0

This sounds like a serious bug, would you please report it to the Github Issue Tracker?

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.