Kibana showing a missing index pattern (for an index that exists), Index Pattern fails at looking up field mappings

Running Kibana 7.8.0 on Elasticsearch Service, I have/had an existing filebeat index pattern, today when loading a dashboard that references it I got the following error.

Error fetching fields for index pattern filebeat-* (ID: 433b1d50-c2dd-11ea-a5cf-618152cb691a)

I tried deleting and recreating the index pattern but I still receive the same error.

Are you using the security solution that ships with the standard Kibana distribution?
If yes, the user you are accessing the dashboard with might not have access rights for the filebeat index. Review the roles associated with the user and make sure it includes read rights to filebeat-* .
Can you check that please - also logs of ES and kibana will help.


I am using Elasticsearch Service so I am not sure how to pull the Kibana or ES logs.

I am using SAML authentication and this index had no issues prior, as well none of the other indexes are having the same issue, no changes have been made to any ACLs.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.