Kibana v7.11.2 not showing the graph and time range for that data


I just upgraded elasticsearch and kibana from v7.10.0 to v7.11.2 and kibana in discover tab does not show the graph and there is no possibility to select a time range

Also saved objects were no migrated :frowning:
kibana.yml config:

elasticsearch.requestTimeout: 120000
elasticsearch.username: "kibana-server"
elasticsearch.password: "xxx"
elasticsearch.ssl.verificationMode: none
elasticsearch.hosts: ["https://host1:9200","https://host2:9200","https://host3:9200","https://host4:9200","https://host5:9200"]
logging.dest: /var/log/kibana/kibana.log /usr/share/kibana/
pid.file: /var/log/kibana/ 10.x.y.z
server.port: 5601
server.maxPayloadBytes: 2097152 true

Is there a "Show chart" link on the far right of where the timeline would be?

I found the issue: it's the index pattern.
I'm deploying kibana with ansible and at the end I'm POST-ing some configs to the kibana API:

1) POST '/api/saved_objects/index-pattern/filebeat-*?overwrite=true' -d '{"attributes":{"title":"filebeat-*"}}'
2) POST 'api/kibana/settings/defaultIndex' -d '{"value":"filebeat-*"}'

It seems that it does not like it. This can be reproduced by removing the filebeat-* index pattern and run the 2 POSTs.
If I manually create the index pattern, all is good the graph and the time range.
Can you please advise about what's wrong with my API calls ? (again I managed to reproduce it twice by removing the existing filebeat-* index pattern and rerun the 2 POSTs)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.