[Kibana] Visualize / Heatmap / Filter Size & Label Display

Hi all,

I created a Heatmap which y-axis (Product #) against x-axis (Store location)
and would like to apply a filter on y-axis which only included 15000 product #

However, when I apply the filter by json input or Elasticsearch Query DSL,
it returns with an error " The URL for this object is too long, and we can't display it".
Are there any way to fix it? Many thanks

Secondly, it would like to display other fields details in the label rather than just the
Store location, count & Product .
Are there any way to display those extra details in the label?

Thank you very much


image

The error message you posted lists two ways how to do this, did you try that? (especially the first option should be a good approach)

About the second question - this is not possible right now in Kibana.

Dear Joe,

I did, but most of times it prompts the same error message while 1 out of 10,
it returns with an error message: "search_phase_execution_exception"


Thank you for your help

It might be necessary to clean the browser cache and open Kibana in a fresh window - otherwise it's possible the overly long URL stays around and the browser tries to navigate there again.

The search execution is a different problem, hinting at a problem with the query - maybe there's a typo in your json input? I would recommend trying to fix the URL problem before tackling this issue.

Thank you Joe,
I clean the browser cache and open Kibana in a fresh window, then long URL problem solved.
However, it then becomes search execution.
I can confirm there aren't any typo in my json input.
I try to trim down the filter to every 750items, it works fine. But when the filter items increased to more than 1000, then it returns with an error "search_phase_execution_exception".
Thank you

sample of json input:
{
"query": {
"bool": {
"should": [
{"match_phrase": {"REMOV_PART":"4063-18167-1"}},
{"match_phrase": {"REMOV_PART":"4063-18139"}},
{"match_phrase": {"REMOV_PART":"VR4100-03"}},
{"match_phrase": {"REMOV_PART":"VR4100-04"}},
{"match_phrase": {"REMOV_PART":"AE1410BA1"}},
{"match_phrase": {"REMOV_PART":"1218-100"}},
{"match_phrase": {"REMOV_PART":"VD3820"}}
],
"minimum_should_match": 1
}
}
}

Can you try to run the query against Elasticsearch directly from dev tools? This will give you the specific error message. I guess you are hitting some Elasticsearch limit that might be possible to increase via config setting, but I'm not sure which one

Dear Joe,
It returns with the followings, many thanks:-

reason: {type: "query_shard_exception", reason: "failed to create query: maxClauseCount is set to 1024",…}
caused_by: {type: "too_many_clauses", reason: "too_many_clauses: maxClauseCount is set to 1024"}
reason: "too_many_clauses: maxClauseCount is set to 1024"
type: "too_many_clauses"
index: "wilco__insight-val__standard__v2"
index_uuid: "qDWWRbMRTuiUn0NPOXtRSQ"
reason: "failed to create query: maxClauseCount is set to 1024"
type: "query_shard_exception"
shard: 0
grouped: true
phase: "fetch"
reason: ""
type: "search_phase_execution_exception"
reason: "error while executing search"
type: "status_exception"
error: "Bad Request"
message: "status_exception"
statusCode: 400

That's it - you should be able to bump it using indices.query.bool.max_clause_count: https://www.elastic.co/guide/en/elasticsearch/reference/current/search-settings.html

1 Like