Kibana3 causing high cpu loads on ES


(Kellan Strong) #1

Hi all,

I recently been having my cluster CPUs usage going to 100% on a 4 Node
cluster for a while now. Load averages were in the 20s across all 4 nodes
which is not good. I did a curl "localhost:9200/_nodes/stats/http?pretty"

My fluent host is a client node and hosts kibana3 and from this it keeps
opening up http sessions almost every second.

My question is Kibana 4 better optimized to handle larger amounts of Data?

And below is what poped up:
{
"cluster_name" : "elasticsearch",
"nodes" : {
"5KwNSngSQvyF-0T9qfNbow" : {
"timestamp" : 1432330511455,
"name" : "node3",
"transport_address" : "inet[/10.10.0.58:9300]",
"host" : "node3",
"ip" : [ "inet[/10.10.0.58:9300]", "NONE" ],
"http" : {
"current_open" : 6,
"total_opened" : 69
}
},
"h64ZfXtTRlqWDkxzh-OXeA" : {
"timestamp" : 1432330575686,
"name" : "node0",
"transport_address" : "inet[/10.10.1.55:9300]",
"host" : "fluent host",
"ip" : [ "inet[/10.10.1.55:9300]", "NONE" ],
"attributes" : {
"data" : "false",
"master" : "false"
},
"http" : {
"current_open" : 19,
"total_opened" : 2684
}
},
"zHU937fmSjShuvIabVEGZg" : {
"timestamp" : 1432330573074,
"name" : "node1",
"transport_address" : "inet[/10.10.0.56:9300]",
"host" : "node1",
"ip" : [ "inet[/10.10.0.56:9300]", "NONE" ],
"http" : {
"current_open" : 0,
"total_opened" : 287
}
},
"IfMPzQv_T7Chkr4pvt2ILQ" : {
"timestamp" : 1432330572914,
"name" : "node4",
"transport_address" : "inet[/10.10.0.59:9300]",
"host" : "node4",
"ip" : [ "inet[/10.10.0.59:9300]", "NONE" ],
"http" : {
"current_open" : 0,
"total_opened" : 183
}
},
"IiTbLSBTQ_CQAW0Foysa-Q" : {
"timestamp" : 1432330574258,
"name" : "node2",
"transport_address" : "inet[/10.10.0.57:9300]",
"host" : "node2",
"ip" : [ "inet[/10.10.0.57:9300]", "NONE" ],
"http" : {
"current_open" : 0,
"total_opened" : 127
}
}
}
}

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bbd1e6f6-f8c9-4461-b540-b9cf9e3d7288%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2