Lab Enviro Not Working

I recently signed up for the free Kibana for Splunk SPL Users training and tried to setup my lab through Strigo. However, when I log in to strigo, it never brings up a command line. It just shows a blank screen (see screenshot below). I’ve tried restarting the VM, as well as even viewing it through 2 browsers (both Chrome and Firefox) from a Mac. I’ve burned 15 minutes trying to troubleshoot, but don’t know what could be wrong. Can someone please assist?

I too had problems using my work laptop. I can access Strigo only on my personal computer.

Are you using a work laptop (with restrictions) ?

Can you go to Strigo's support page here and see if anything is applicable for you.

No, strigo works on my laptop. I had it work for a lab I did a few months ago, as well as another online course I just tried yesterday

Hi Alex,

This was due to an update to Strigo software which didn't agree with a configuration in the AMI. We fixed it now and I tested it. It seems to be working. Having said that, you don't need the terminal per se for this course. Simply use the gear icon (that still shows up) to get the url for your lab and Kibana and you will be able to proceed.



I started the Data Analysis w/Kibana course but am not able to run the labs. I also can not find any Lab instructions? I have signed up for the Strigo account, and when I click on Lab it takes me to the sign-in Strigo sign-in page. I sign in, and it takes me to the bash terminal. That's the extent of it. How do I start the labs from there? It would be helpful if there were Lab instructions associated with the course.

Hey @bao

It seems the instructions that explain how to access the lab are missing. Sorry about that. We will fix it as soon as possible.

To help you get started, I'll post the instructions here:

  • Just above the linux terminal in Strigo, you should see a little gear icon. Click it, and a menu will pop up.

  • Choose "Machine Info" from the menu

  • This will show you a popup, with a hostname under "Public DNS". The hostname starts with ec2- and ends with Copy the entire hostname.

  • Open a new tab in your browser, and paste the hostname in the address bar.

  • This will bring you to a page with lab instructions.

Once you access Strigo, it may take 15-20 minutes for Kibana to start. If you get a "502" error, wait a few minutes and try again

When I try to access the "" resource (copy / paste to new browser tab), it times out, it does not bring up lab instructions.

The instruction page finally loaded. Looks like I am good to go, thanks.

Great! My apologies again, for your troubles. Hope you enjoy the course!


I've been trying to get Kibana to start for the past 25 minutes (502 error as you said), but still no Kibana. In the mean time, Strigo is running and using up the time allotted for the labs. I'm assuming I need to be logged into Strigo in order to access the EC2 Kibana resource?

I have to say, this entire process of trying to get the lab running has been very frustrating.


Hi Brian,

Can you try this: In the Bash terminal, first type the following (and answer "yes" when prompted):

ssh server1

Next, once logged in, type the following to start Kibana manually:


After a couple of minutes, the 502 error should go away.

When I try to SSH into server 1, it does not connect, it just times out.

elastic@ip-172-31-0-233:~$ ssh server1
ssh: connect to host server1 port 22: Connection timed out

Hi Abdon,

I just replied on the discussion forum as well…

When I try to SSH into server1, it times out…does not establish a connection.


Can you please send me a direct message with your email address? We will then replace your lab environment with a fresh one that hopefully will not have these issues.


I'm also having the same problems. Is that something you can assist me with as well? SSH to server1 times out.

I am facing the same problem, SSH does not work either. Its disappointing that i can't access my lab environment after paying for it.

We are looking into this issue.

@lsly and @Manish_Sharma can you please open a new thread next time. This thread is older than a month and is related to another problem.

Still, thank you very much for reaching out to us. This is a new issue that seems to be affecting many of our users in the last days, even though we had no updates applied. I am wondering if there is an issue with Strigo or more specifically AWS in the way they serve their instances.

We are currently investigating and will let you know what we find out. The short term solution we can offer you is to replace your lab environment, which means things will work again (at least initially). Unfortunately, you will lose any work done. Send me a private message with your email if you want to follow this path and I will replace your labs.

BTW, this issue might be a better one to follow up on the current problem:

That would be great.. please change the lab.

Please send me by private message the course you are enrolled in and the email you use to access it. For example:

course: Engineer I