Line chart and data table in kibana show different numbers


(ilanas) #1

This post is the same as 'Kibana: Data Table and Line Chart have different numbers'. I have the same issue and i don't know how solve this issue. I'm using kibana 6.2.2.
Thanks


(Nathan Reese) #2

Could you please include the URL to the post that you are referring too?


(ilanas) #3

(ilanas) #4

can anybody help me? please


(ilanas) #5

I have tried to do the same with a bar chart and it gives me the same error. All graphics get me the wrong data. Except the table. some help?


(ilanas) #6

I have discovered something curious in case you can help me. The first image shows the discover so you can have an idea of ​​what each record has. The second is what I seek to do and what gives an error (Sum the amounts wrong). The third option makes the sum well but the line graph is ugly


2
3


(ilanas) #7

if cursonombre is anterior -2 then importe have the same value of anterior-2 and anterior, actual and anterior -1 are 0


(ilanas) #8

do you understand my question? I don't know why appens this...


(Nathan Reese) #9

Can you try reproducing your problem with one of the sample data sets so I can try and reproduce on my end?

Sample data sets were introduced in Kibana 6.4


(ilanas) #10

i have 6.2.2 in kibana. How can i migrate to 6.4?


(Nathan Reese) #11

What is the cardinality of DEPARTAMENTO? Try moving that aggregation above the x-axis aggregation so each x-axis bucket is working with the same DEPARTAMENTO values


(Nathan Reese) #12

You do not have to upgrade but rather, just phrase your question/problem in the context of a sample data set so we are looking at the same thing.

I am not sure what the problem is and it is hard to see without the data set, what you are expecting, how the values are different, and so on.

If you could just stand up a new 6.4 stack and recreate the problem and use that example that would really help


(ilanas) #13

i put departamento above x-axis and nothing. What refers with cardinality?


(ilanas) #14

Just i solved!!! i change the sql query and i don't know because but now the chart are well!!


(system) #15

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.