Linked indices shown 0 even after adding it to lifecycle


I am usning Elastic search 6.7.

I have created policies in the lifecycle management index and added indices to it. But the status is shown 0. Any idea how can I see what inxdex is connected to which lifecycle policy and how I can add and delete an index.

In actions I only see these two options. Do I need to upgrade ES and kibana for more features?


Hi Fayaz,

It looks like you've created a policy, but you don't have any indices that use that policy. There are 2 ways you can start using the policy.

The first is to create and index (or update its settings) with the setting to be the policy that you created. Something like (to create a new index using a policy):

PUT /myindex
  "settings": {
    "": "metricindex"

The other would be to create an index template (this is what the "Add policy to index template" button will let you do) so that any new indices that are created that match a pattern will automatically start using your ILM policy.

@dakrone This issue got resolved. But I see those indexes added to the lifecycle name but I see a different error now.

Okay, you can use the ILM explain API to see why those indices have errors in their ILM policies.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.