Logstash-input-redis fails to install due to ruby version 2.2.2


(Alfredo Matos) #1

When trying to install logstash-input-redis, the plugin install fails due to the redis gem requiring ruby version >= 2.2.2.

Running:

JARS_DEBUG=true JARS_VERBOSE=true DEBUG=1 /usr/share/logstash/bin/logstash-plugin update

The system is a ubuntu 16.04 running on AWS. Logstash version 5.5.2.

Gem::InstallError: redis requires Ruby version >= 2.2.2.
/usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/installer.rb:560:in `ensure_required_ruby_version_met'
/usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/installer.rb:782:in `pre_install_checks'
/usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/installer.rb:231:in `install'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/source/rubygems.rb:114:in `install'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/rubygems_integration.rb:131:in `preserve_paths'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/source/rubygems.rb:113:in `install'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:107:in `install_gem_from_spec'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:269:in `install_sequentially'
org/jruby/RubyArray.java:1613:in `each'
/usr/share/logstash/vendor/jruby/lib/ruby/1.9/forwardable.rb:201:in `each'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:268:in `install_sequentially'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:90:in `run'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:18:in `install'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli/update.rb:51:in `run'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli.rb:178:in `update'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in `invoke_command'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor.rb:359:in `dispatch'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/base.rb:440:in `start'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli.rb:10:in `start'
/usr/share/logstash/lib/bootstrap/bundler.rb:168:in `execute_bundler'
/usr/share/logstash/lib/bootstrap/bundler.rb:129:in `invoke!'
/usr/share/logstash/lib/pluginmanager/update.rb:67:in `update_gems!'
/usr/share/logstash/lib/pluginmanager/update.rb:32:in `execute'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11:in `execute'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'
/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'
/usr/share/logstash/lib/pluginmanager/main.rb:48:in `(root)'
Bundler::InstallError: An error occurred while installing redis (4.0.0), and Bundler cannot continue.
Make sure that `gem install redis -v '4.0.0'` succeeds before bundling.
  install_gem_from_spec at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:145
   install_sequentially at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:269
                   each at org/jruby/RubyArray.java:1613
                   each at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/forwardable.rb:201
   install_sequentially at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:268
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:90
                install at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:18
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli/update.rb:51
                 update at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli.rb:178
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/command.rb:27
         invoke_command at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/invocation.rb:126
               dispatch at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor.rb:359
                  start at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/base.rb:440
                  start at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli.rb:10
        execute_bundler at /usr/share/logstash/lib/bootstrap/bundler.rb:168
                invoke! at /usr/share/logstash/lib/bootstrap/bundler.rb:129
           update_gems! at /usr/share/logstash/lib/pluginmanager/update.rb:67
                execute at /usr/share/logstash/lib/pluginmanager/update.rb:32
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
                execute at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
                 (root) at /usr/share/logstash/lib/pluginmanager/main.rb:48

Any ideas on how to work around this error, and get the plugins to finish updating?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.