Logstash RPM on centos5.x

Hello,

I am having no problems using the elasticsearch logstash yum repo on
centos6.x, but when I try on centos5.x I am not able to get an rpm to
install.

This is the error I get when I use the 1.3 repo:

http://packages.elasticsearch.org/logstash/1.3/centos/repodata/primary.sqlite.bz2:
[Errno -3] Error performing checksum
Trying other mirror.
primary.sqlite.bz2 | 2.6 kB 00:00

http://packages.elasticsearch.org/logstash/1.3/centos/repodata/primary.sqlite.bz2:
[Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.sqlite.bz2 from logstash-1.3: [Errno 256]
No more mirrors to try.

Here is my repo file:

[logstash-1.3]

name=logstash repository for 1.3.x packages
baseurl

baseurl=http://packages.elasticsearch.org/logstash/1.3/centos

gpgcheck=1

gpgkey=http://packages.elasticsearch.org/GPG-KEY-elasticsearch

enabled=1

I have tried turning off gpgcheck as well and I get the same error.
I also tried just downloading the rpm directly and then installing it
without yum and I get this:

[root@host ~]# rpm -q -p logstash-1.3.2-1_centos.noarch.rpm
error: logstash-1.3.2-1_centos.noarch.rpm: Header V4 RSA/SHA1 signature:
BAD, key ID d88e42b4

I believe that is caused by signing an rpm with V4, which centos5 is not
compatible with.

Here is my uname:
[root@host ~]# uname -a
Linux host 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64
x86_64 GNU/Linux

Is there a different repository I should be using for centos/redhat 5.x?

Thank you,
Kevin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6596039b-5be9-4d8e-aef6-eff9f190b8ae%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Kevin,

The Packages are signed on a CentOS 6.x machine indeed which uses the V4
sigs.
CentOS 5.x uses the V3 sigs but we are unable to create those sigs from a
CentOS 6.x machine.
I'll get back to you if/when we setup a special repo for CentOS 5.x.

In the meantime you could use the non signed packages:
http://download.elasticsearch.org/logstash/logstash/packages/centos/logstash-1.3.3-1_centos.noarch.rpm

On Wednesday, January 29, 2014 1:02:08 AM UTC, Kevin Pearson wrote:

Hello,

I am having no problems using the elasticsearch logstash yum repo on
centos6.x, but when I try on centos5.x I am not able to get an rpm to
install.

This is the error I get when I use the 1.3 repo:

http://packages.elasticsearch.org/logstash/1.3/centos/repodata/primary.sqlite.bz2:
[Errno -3] Error performing checksum
Trying other mirror.
primary.sqlite.bz2 | 2.6 kB
00:00

http://packages.elasticsearch.org/logstash/1.3/centos/repodata/primary.sqlite.bz2:
[Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.sqlite.bz2 from logstash-1.3: [Errno 256]
No more mirrors to try.

Here is my repo file:

[logstash-1.3]

name=logstash repository for 1.3.x packages
baseurl

baseurl=http://packages.elasticsearch.org/logstash/1.3/centos

gpgcheck=1

gpgkey=http://packages.elasticsearch.org/GPG-KEY-elasticsearch

enabled=1

I have tried turning off gpgcheck as well and I get the same error.
I also tried just downloading the rpm directly and then installing it
without yum and I get this:

[root@host ~]# rpm -q -p logstash-1.3.2-1_centos.noarch.rpm
error: logstash-1.3.2-1_centos.noarch.rpm: Header V4 RSA/SHA1 signature:
BAD, key ID d88e42b4

I believe that is caused by signing an rpm with V4, which centos5 is not
compatible with.

Here is my uname:
[root@host ~]# uname -a
Linux host 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64
x86_64 x86_64 GNU/Linux

Is there a different repository I should be using for centos/redhat 5.x?

Thank you,
Kevin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/870476ad-1345-4821-b8ee-6de517f481e9%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Richard,

With CentOS 6 you can still sign packages with v3 signatures. If you could
do this it would be great, as I had the same issue as Kevin. The issue (and
workaround) is mentioned in the web page:
http://adminotes.blogspot.co.uk/2011/12/centos-6-rpm-sign-problem-v4-signatures.html

Kevin: The work-around is to delete the signature on the RPM. It does mean
a manual installation via RPM (or you need to create a repo of your own, of
"rpms without signatures", which will probably only be of benefit for
multiple machines). Just:

rpm --delsign logstash-1.3.3-1_centos.noarch.rpm

Hope that helps

Cheers

Ivan

On Wednesday, 29 January 2014 11:21:43 UTC, Richard Pijnenburg wrote:

Hi Kevin,

The Packages are signed on a CentOS 6.x machine indeed which uses the V4
sigs.
CentOS 5.x uses the V3 sigs but we are unable to create those sigs from a
CentOS 6.x machine.
I'll get back to you if/when we setup a special repo for CentOS 5.x.

In the meantime you could use the non signed packages:
http://download.elasticsearch.org/logstash/logstash/packages/centos/logstash-1.3.3-1_centos.noarch.rpm

On Wednesday, January 29, 2014 1:02:08 AM UTC, Kevin Pearson wrote:

Hello,

I am having no problems using the elasticsearch logstash yum repo on
centos6.x, but when I try on centos5.x I am not able to get an rpm to
install.

This is the error I get when I use the 1.3 repo:

http://packages.elasticsearch.org/logstash/1.3/centos/repodata/primary.sqlite.bz2:
[Errno -3] Error performing checksum
Trying other mirror.
primary.sqlite.bz2 | 2.6 kB
00:00

http://packages.elasticsearch.org/logstash/1.3/centos/repodata/primary.sqlite.bz2:
[Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.sqlite.bz2 from logstash-1.3: [Errno
256] No more mirrors to try.

Here is my repo file:

[logstash-1.3]

name=logstash repository for 1.3.x packages
baseurl

baseurl=http://packages.elasticsearch.org/logstash/1.3/centos

gpgcheck=1

gpgkey=http://packages.elasticsearch.org/GPG-KEY-elasticsearch

enabled=1

I have tried turning off gpgcheck as well and I get the same error.
I also tried just downloading the rpm directly and then installing it
without yum and I get this:

[root@host ~]# rpm -q -p logstash-1.3.2-1_centos.noarch.rpm
error: logstash-1.3.2-1_centos.noarch.rpm: Header V4 RSA/SHA1 signature:
BAD, key ID d88e42b4

I believe that is caused by signing an rpm with V4, which centos5 is not
compatible with.

Here is my uname:
[root@host ~]# uname -a
Linux host 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64
x86_64 x86_64 GNU/Linux

Is there a different repository I should be using for centos/redhat 5.x?

Thank you,
Kevin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3a0e8cb2-292d-4339-a648-9d523c1447f8%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Is there a different repository I should be using for centos/redhat 5.x?

You should be able to get the v4 repository working in your CentOS/RHEL5
distro by installing the python-hashlib package.

Description: This is a stand alone packaging of the hashlib library
introduced in Python 2.5 so that it can be used on older versions of Python.

Once this is installed the new repo should work fine and you don't need to
mess around with signatures.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2ecf899b-8103-4b85-918f-35c840fb2525%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.