Make Elasticsearch running as a service?

Hello, i've installed the elasticsearch 7.x on a raspberry PI 4B on ubuntu 20.04.
I've installed it manually with the .tgz.
It's working fine when i launch it manually with the command :
./elasticsearch -d
(in the directory /etc/elasticsearch/bin/)
It's working only when i run it from the user ubuntu but don't work with the user root (i don't know why)
I need to run it automatically from the start of the raspberry pi without running any commands.
Like if i would do : service elasticsearch enable
But i need help, i tried to make a file on the systemd, but it's not working well.

Could you please help me ? I'm kinda lost.

Thank you

Welcome to our community! :smiley:

You should try the aarch packages, these will include an init script - Download Elasticsearch Free | Get Started Now | Elastic | Elastic

In which folder do you see the init script?

I don't see it ! Thank you very much

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.