Manual delete of indices on elastic search not freeing up space

I have 2TB of indices. It just hit the flood stage watermark. I resolved this via CURL and now it allows manually deleting some indices. It removes them from Kibana, etc. I can delete it via curl or Kibana and it is acknowledged and removed. It is however not freeing up the space.

  • I went ahead and also removed the ILM from the index before deleting a few indices, still no luck.
  • Although I removed a whole index, also tried POST _forcemerge to no avail.

How can I recover space now that the indices are deleted?

Welcome to our community! :smiley:

If you removed them via curl then they should be removed from the disk.
What is the output from GET /_cat/nodes?v=true&h=id,ip,v,d?

Thanks for your response!

After hours I found that it was a ZFS issue with snapshots! I got rid of the snapshots and the space was recovered correctly, thanks again for your response.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.