Map Visualization in Tutorial Does not work

I have gone through this tutorial using Elasticsearch and kibana 4 on Found in the cloud:

I have everything working except the map visualization example. My data (from the tutorial files) shows the geo codes in the discover tab, but when I follow the steps I get "no results found". As seen here:

What could I be doing wrong?

I can reproduce this problem - our team will investigate tomorrow. Thank you for reporting!

Here's the GH issue for this

Thanks, now I know it is not due to my raw inexperience. :blush:

I had geohash codes embedded into my data and was getting the same issue. I changed that to a nested latitude-longitude datum and set its type as geo_point. My map is working well now.
Would like to know this issue though.

Mr. Lawson:

Sorry for your bad experience with the tutorial! With current versions of Elasticsearch, this dataset needs a geolocation mapping to work properly.

To clear the data from a previous import, execute the following commands:

curl -XDELETE http://localhost:9200/logstash-2015.05.18
curl -XDELETE http://localhost:9200/logstash-2015.05.19
curl -XDELETE http://localhost:9200/logstash-2015.05.20

Before importing the logs.jsonl file to Elasticsearch, establish the mappings with the following command:

curl -XPUT http://localhost:9200/logstash-2015.05.18 -d '
"mappings" : {
"log" : {
"properties" : {
"geo" : {
"properties" : {
"coordinates" : {
"type" : "geo_point"

Repeat that mapping for the other two dates, 2015-05-19 and 2015-05-20, then import logs.jsonl according to the tutorial's instructions.

You may need to refresh your indexes by navigating to Settings > Indices in the Kibana UI, selecting the logstash-* index pattern, and clicking the yellow Refresh button.

I'll update the documentation to reflect this step soonest.

Paul Echeverri
Senior Technical Writer

(edit: corrected the mapping, added directions on clearing old indices)

1 Like