Map visualizations have stopped working due to MapQuest change July 11, 2016


(Jhendric98) #1

It appears mapquest has changed their public access to direct tile downloads. Am I reading this correctly or is there misconfig on my Kibana server. All my maps now have mapquest error tiles loading.

link to Mapquest site


(Rene) #2

I have the same message. I was about to open a topic about this, but you were just a little quicker than me :slight_smile:


Kibana 4.5.4 Tilemap
(Jhendric98) #3

I thought it might be an issue of pulling the latest patch. I updated to current patch and that didn't resolve it either.


Kibana Tile Map Discontinued Access to Mapquest
(Mark Walkom) #4

We've just become aware of this ourselves :frowning:
The Kibana team is looking at our our options and we will get back to you as soon as we can!


(Jhendric98) #5

Thanks for the update guys. :slight_smile:


(Rene) #6

I already opened https://github.com/elastic/kibana/issues/7717 for this.


(Leo) #7

Same here...I have a demo in two weeks and I got this issue thanks for checking!!


#8

Same, but i've tested this url with success in WMS compliant map server kibana options :
http://irs.gis-lab.info/?layers=osm&


Kibana Tile Map error
(Meenal Luktuke) #9

We need a solution at the earliest. I had a demo today and my clients were shocked at the dashboard.
Thanks for updating, but please suggest a solution asap.


(Francisco Andrades) #10

There are several solutions posted in the GitHub discussion: https://github.com/elastic/kibana/issues/7717


(Jon Budzenski) #11

Patch releases for 4.1 and 4.5 are up: https://www.elastic.co/blog/kibana-4-5-3-and-4-1-10


(jpry) #12

What about version 4.3.0. I have the same problem here.


(Court Ewing) #13

@jpry We're working on getting this backported to 4.3, but we're still not even sure if it's feasible. 4.5 and 4.1 are the only currently maintained versions, so they're the only ones we knew for sure could get the update.


(jpry) #14

Okay, so either I update KIBANA and apply the patch or use an alternative.

I actually tried what jamesspi proposed in the discussion: https://github.com/elastic/kibana/issues/7717 . It worked pretty well.


#15

i have installed kibana 4.5 and its dependencies now I am trying to use MapQuest consumer key along with its url in kibana.yml file in tilemap-url ,but somehow it is not working . is there anything i am missing ? i am not getting why it is not showing up? any help would be greatly appreciated .


(St├ęphane Klein) #16

It's possible to use Google Maps tile ou OpenStreetMap ?


(Seth S) #17

I believe that violates googles TOS, if I remember correctly, if you find otherwise, please inform us!


(system) #19