Mapping date type got wrong date

Hi everyone
i am quite new to elastic so i need your help with this problems
i parse the date time of a log with the name timestamp, then i put the type of mapping for it as date but the time that show on kibana is wrong, the time show when the log collected is UTC+7 since i am in that timezone but the time show on the timestamp are just UTC
So are there any way to make the mapping type to convert them to UTC+7

Thank you


It's possible that this is just a display issue. By default Kibana will show timestamps in the timezone of your browser. Either make sure your browser is also set to UTC+7 or set the Kibana time zone manually in the advanced settings (dateFormat:tz).

If this does not solve your problem, something is indeed wrong with your mapping and Elasticsearch isn't capturing the time zone correctly during ingest. If that's the case, please head over to the Elasticsearch forum and post your mapping and an example document there.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.